Bug 88113 - Installer starts, but fails to use dvd/cdrom once installation begins
Installer starts, but fails to use dvd/cdrom once installation begins
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-04-05 19:15 EST by Chris Croswhite
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-04-07 16:05:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Croswhite 2003-04-05 19:15:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Installer begins normal with booting from cdrom, asks which language, then 
keyboard setting, type of media (Local CDROM) and then says it can not find the 
Red Hat CDROM in any of the CDROMS (even though there is just one).  When I 
select "Local CDROM", it indicates that the cdrom is not found (though it never 
tries to hunt on the cdrom).

Checking f4 screen, it shows huge errors on the ATAPI device cdrom (status 
error: status=0x00 {} and status error: error=0x00) several times around.  I am 
assuming something is not going well when trying this ide device.  Perhaps a 
missed or improper driver loaded for the ide bus?

I have tried nodma, biosirq (this helped out another error) and noapic to no 
avail.  Also, I have tried both NFS images and FTP but even the NIC fails to be 

I need to get this solved ASAP or will have to move to a different distribution.


Version-Release number of selected component (if applicable):
have tested 7.3, 8, 9

How reproducible:

Steps to Reproduce:
1.Boot into installer
2.Anser language, keyboard and then mdeia questions

Actual Results:  Failed to detect cdrom

Expected Results:  Install of RH

Additional info:
Comment 1 Chris Croswhite 2003-04-05 19:20:41 EST
Compaq Evo N1015v with DVD-ROM, Athlon XP 1800, Realtek RTL8139C+ NIC, 30G HD, 
ALi 710X (7101) Chip-set.

Comment 2 Michael Fulbright 2003-04-07 14:24:21 EDT
This is either a bad CD or a kernel issue with this IDE chipset I believe. I
think I've seen one other report.
Comment 3 Chris Croswhite 2003-04-07 14:29:19 EDT
I used Suse this weekend to get around the problem.  It appears that as soon as 
the USB drivers are loaded, the ide bus goes south.  The question to redhat, 
how can I get the install kernel not to load any usb module?  Under suse, they 
have a manual mode that allows me to say no to the USB drivers and subsequently 
install.  I can not find this option in RedHat (7.2, 7.3, 8.0, 9.0) and yes, I 
have now bought all of them.

Please let me know if this is possible with RH.

Comment 4 Arjan van de Ven 2003-04-07 14:31:47 EDT
it surely is possible
you have to pass "nousb" as kernel option; you can do this on the grub screen by
pressing the "a" or "e" keys (for the vmlinuz line); on the linux: installer
screen you also can type "nousb". 

Also pleae see bug 72387 for other radeonIGP issues
Comment 5 Alan Cox 2003-04-07 14:40:38 EDT
For Red Hat 9 you need "nousb and/or ide=nodma" either will work.

I'm still trying to finalise support for this chipset but there are complications. I
think no current distribution supports it well. The good news is that you can
certainly make Red Hat 8, 9 and Mandrake 9.x run on it.

I'd recommend reading:

This site has custom kernels with the needed changes and required ACPI support
Comment 6 Chris Croswhite 2003-04-07 16:04:36 EDT
Okay, tried the "nousb" option this worked.  In order to get around this bad 
(crappy) chipset, you also need the nopcmcia and noprobe options.  I am now 
installing RH on the laptop.  Thanks for the help.  Will give the mentioned 
website a gander.


Note You need to log in before you can comment on or make changes to this bug.