Bug 8812 - 66305-cylinder disk shows up as 769-cylinder in fdisk.
66305-cylinder disk shows up as 769-cylinder in fdisk.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
6.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-24 18:05 EST by xkr47
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-18 05:47:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xkr47 2000-01-24 18:05:53 EST
My new IBM 34gb harddisk is identified correctly at boot time as 66305
cylinder (16 heads, 63 sectors). However, when I start up fdisk it shows me
769 cylinders, which is equal to the lowest 16 bits of 66305. "sfdisk -g"
also shows the disk as 769-cylinder. However, cfdisk correctly displays the
number of cylinders (after creating a empty partition table with fdisk).

I guess if I had used some other DOS or Windows based utility (urgh) then
that util might have wrapped the whole disk into (4160,255,63) or whatever
and this problem wouldn't have occured since I've noticed that linux
detects the actual used parameters (if it can) from the partition table.
Comment 1 Elliot Lee 2001-07-16 19:49:27 EDT
Michael, is this a kernel bug as Matt suggested?
Comment 2 Arjan van de Ven 2001-07-18 05:47:55 EDT
Red Hat Linux 6.1 had an fdisk that couldn't cope with such large disks.
I'd recommend upgrading the fdisk to at least the 7.0 version.

Note You need to log in before you can comment on or make changes to this bug.