Bug 88135 - Cannot adjust clock
Cannot adjust clock
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-06 11:01 EDT by Jeremy
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-04 13:08:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scrnshot (77.87 KB, image/png)
2003-06-03 21:28 EDT, Jeremy
no flags Details

  None (edit)
Description Jeremy 2003-04-06 11:01:45 EDT
Description of problem:
Cannot adjust date and time on clock



Version-Release number of selected component (if applicable):2.0.6



How reproducible:
Right click on the clock in the panel ,choose "adjust date and time"
enter root password when asked , nothing happens.


Steps to Reproduce:
1.Right Click on Clock in Panel
2.Select "Adjust Date and Time
3.Enter root password when asked
    
Actual results:
Absolutely nothing happens after the above is completed


Expected results:
To be able to adjust the clock

Additional info:
New install of RH8.0 ,all updates applied
Comment 1 Brent Fox 2003-05-08 10:44:11 EDT
Can you try running 'redhat-config-date' from the command line and then
cut-and-paste the output into this bug report?  There should be some debugging
information that might explain what's going on.
Comment 2 Jeremy 2003-05-08 18:06:05 EDT
[Jeremy@localhost Jeremy]$ redhat-config-date
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in __init_
_
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in setCurr
ent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'
[Jeremy@localhost Jeremy]$
Comment 3 Brent Fox 2003-05-09 12:01:04 EDT
Thanks.  This bug is a duplicate of bug #76313.  An update is available at
ftp://ftp.redhat.com/pub/redhat/linux/9/en/os/i386/RedHat/RPMS/redhat-config-date-1.5.9-8.noarch.rpm
Comment 4 Jeremy 2003-05-10 19:41:46 EDT
downloaded and applied patch......
did absolutely nothing......

still cannot adjust clock...

any other words of wisdom.....??

Comment 5 Brent Fox 2003-05-19 21:00:10 EDT
Do you see the exact same error message on the command line?
Comment 6 Jeremy 2003-05-22 22:13:57 EDT
Further to your request for needed info , 
here again is the output from redhat-conig-date....
Looks almost the same as last time....
even after installing the patch....still no clock adjustment possible...

LOL!!

It's a small thing ,but a niggling thing....

Thanks again for your assistance.

(Paste):

Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in __init_
_
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in setCurr
ent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'
[root@localhost Jeremy]#

Comment 7 Brent Fox 2003-05-23 15:24:02 EDT
Very strange.  Can you attach the contents of /etc/sysconfig/clock?
Comment 8 Jeremy 2003-05-30 23:23:47 EDT
/etc/sysconfig/clock says......


           ZONE="Etc/GMT-4"
           UTC=false
           ARC=false


That is all........

Thanks for taking the time....

Comment 9 Brent Fox 2003-06-02 11:37:00 EDT
Hmm...I'm really confused now.  Are you sure that you installed
redhat-config-date-1.5.9-8 from the ftp link I posted above?  

Here's why I ask:

File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in setCurrent
    self.markers[self.currentEntry.tz].hide()

This part of the traceback indicates that the
self.markers[self.currentEntry.tz].hide() statement is on line 180.  

However, after I made the following patch on Oct. 22, 2002, that line should be
on line 181:

Update of /usr/local/CVS/redhat-config-date/src
In directory elvis.redhat.com:/tmp/cvs-serv27076/src

Modified Files:
        timezone_map_gui.py 
Log Message:
fix bug 76313

Index: timezone_map_gui.py
===================================================================
RCS file: /usr/local/CVS/redhat-config-date/src/timezone_map_gui.py,v
retrieving revision 1.11
retrieving revision 1.12
diff -u -r1.11 -r1.12
--- timezone_map_gui.py 21 Aug 2002 23:08:35 -0000      1.11
+++ timezone_map_gui.py 22 Oct 2002 15:16:01 -0000      1.12
@@ -174,9 +174,10 @@
         if not entry:
             # If the value in /etc/sysconfig/clock is invalid, default to New York
             self.currentEntry = self.fallbackEntry
+        else:
+            self.currentEntry = entry
 
         self.markers[self.currentEntry.tz].show()
-        self.currentEntry = entry
         self.markers[self.currentEntry.tz].hide()
         x, y = self.map2canvas(self.currentEntry.lat, self.currentEntry.long)
         self.current.set(x=x, y=y)

So the traceback you are currently seeing leads me to believe that you are still
running an older version of redhat-config-date.

Run 'rpm -q redhat-config-date' to see what version is installed.  I'll bet that
the version is earlier than redhat-config-date-1.5.9-8.
Comment 10 Jeremy 2003-06-02 22:44:13 EDT
Looks like you are correct....the version is older - see below...

I did download the patch and I was pretty sure it installed , but i guess not...
I will give it another go....

I am beginning to think my installation is corrupt....
Most of it works pretty good , but I have since discovered a few other
quirks...
I think it's time to try RH 9.0.......

Linux is still new to me....
There's still A LOT that I have not figured out....

Maybe it's something about my hardware that is causing  this...(??)

Again , 

May thanks for your help.


Cut/paste frm query...

[Jeremy@localhost Jeremy]$ su
Password:
[root@localhost Jeremy]# rpm -q redhat-config-date
redhat-config-date-1.5.2-10
[root@localhost Jeremy]#

Comment 11 Jeremy 2003-06-03 21:28:44 EDT
Created attachment 92130 [details]
scrnshot
Comment 12 Jeremy 2003-06-03 21:32:16 EDT
as you can see by the screen shot , it unpacked and installed OK..
I can now change my time like I am supposed to be able to...

Things are right with the world !!!!

But the question remains....why would it not install by just clicking on the
RPM...???

Many,many thanks again for your help....

Jeremy
Comment 13 Brent Fox 2003-06-04 13:08:40 EDT
I can't explain why double clicking the rpm in Nautilus didn't work.  That still
bothers me since that shouldn't happen.  But at least your redhat-config-date is
working now.

Glad to be of help.  Closing as "Rawhide"

Note You need to log in before you can comment on or make changes to this bug.