This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 881370 - db4 ftbfs on ARM
db4 ftbfs on ARM
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: db4 (Show other bugs)
18
arm Linux
unspecified Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-11-28 14:34 EST by Paul Whalen
Modified: 2013-07-02 19:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 05:02:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Whalen 2012-11-28 14:34:03 EST
Description of problem:
db4 ftbfs on arm due to use of long form triplet 'armv7hl-redhat-linux-gnueabi-gcc', requires the use of '--tag=CC' in the spec file. 

Version-Release number of selected component (if applicable):

Occurs on all versions of db4 in F18.

How reproducible:

Always.

Steps to Reproduce:
1. Attempt to build from source
2. Build fails.
  
Actual results:

Output from build.log - 

+ /bin/sh libtool --mode=compile armv7hl-redhat-linux-gnueabi-gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard -Idb.1.85/PORT/linux/include -D_REENTRANT -c db_dump185/db_dump185.c -o dist/dist-tls/db_dump185.lo
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
error: Bad exit status from /var/tmp/rpm-tmp.P7uLIx (%build)
    Bad exit status from /var/tmp/rpm-tmp.P7uLIx (%build)


Expected results: 

Successful build.

Additional info:

Link to build failure - http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1268178

When using '--tag=CC' in the spec file, the build is successful.
Comment 1 Peter Robinson 2013-01-09 05:02:47 EST
db4 has been renamed to libdb4 and that builds fine on F-18. db4 shouldn't be used.

http://arm.koji.fedoraproject.org/koji/packageinfo?packageID=14153

Note You need to log in before you can comment on or make changes to this bug.