Bug 88149 - dateconfig fails to correctly update the system clock
dateconfig fails to correctly update the system clock
Status: CLOSED DUPLICATE of bug 66417
Product: Red Hat Linux
Classification: Retired
Component: dateconfig (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Depends On:
  Show dependency treegraph
Reported: 2003-04-06 18:48 EDT by Need Real Name
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:52:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
ntp conf as requested (2.72 KB, text/plain)
2003-05-16 23:26 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-04-06 18:48:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Description of problem:
as daylight savings happened this morning, i checked my system clock and
discovered it off again by about 3 minutes. i determined this by going to
http://www.worldtimeserver.com/time.asp?locationid=US-CA (which i believe to be
fairly accurate - but only to within one minute thanks to http delays, etc).
i've been using dateconfig with ntp enabled and pointed at time.nist.gov for
updates. ntp is definitely running. however it appears that ntp isn't updating
my system clock. 

although it wasn't applicable, i applied the patch from bug#64329.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
i selected "every time" for reproducibility, but it is difficult to reproduce
because the time skew happens so slowly. the system has been running for about
40 or 50 days since the last time i manually updated the clock. i'm guessing it
lost about a second a day or so.

Expected Results:  ntp should update the system clock at least once per day.
thus the system clock should be reasonably accurate.

Additional info:
Comment 1 Brent Fox 2003-05-16 12:13:48 EDT
Can you attach your /etc/ntp.conf file?  
Comment 2 Need Real Name 2003-05-16 23:26:29 EDT
Created attachment 91754 [details]
ntp conf as requested

this file has been modified several times since filing the bug. dateconfig
still fails to update the system clock. i've been running ntpdate from cron,
which has been a bit more successful.
Comment 3 Brent Fox 2003-05-21 15:22:26 EDT
Hmm...the file looks ok to me.  I really have no idea why this would happen. 
ntp works fine for all of us here.  I'm not sure what to do.  :(

What is the contents of the /etc/ntp/step-tickers file?
Comment 4 Need Real Name 2003-05-21 21:52:24 EDT
/etc/ntp/step-tickers is a zero-length file.

what's really disturbing about this issue is my system clock is now losing as
much as 5 minutes a day. this started happening after i upgraded my kernel to
Comment 5 Brent Fox 2003-05-21 22:40:05 EDT
Hmm...I'm becoming convinced that this problem has nothing to do with dateconfig.  

After doing a quick Bugzilla query, I ran across bug #66417.  This sounds almost
identical to your problem.  I think this report is a duplicate of that bug.

*** This bug has been marked as a duplicate of 66417 ***
Comment 6 Red Hat Bugzilla 2006-02-21 13:52:31 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.