Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 881541 - UTF-8 characters not displayed correctly.
Summary: UTF-8 characters not displayed correctly.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: Terminal
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-29 04:00 UTC by Dave Jones
Modified: 2015-01-04 22:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-30 22:06:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Dave Jones 2012-11-29 04:00:41 UTC
Worked fine in F17. Font set to liberation mono, (though same effect with any other font I've tried).

Characters are rendered as a series of boxes.

As an example: When I run printf '\xe2\x99\xaa\n';

Instead of "♪" I see "âª"

Comment 1 Kevin Fenzi 2012-11-29 13:28:21 UTC
Odd. This is Xfce's "Terminal" app right?

Whats in /etc/locale.conf ?

Do any other terminals work?

Comment 2 Dave Jones 2012-11-30 20:35:41 UTC
Yes. Xfce's. Though gnome-terminal does the same.

locale.conf says..

LANG="en_US"

hmm. My 17 box had LANG=en_US.UTF-8 there.
I'll try changing that.

Comment 3 Dave Jones 2012-11-30 21:15:16 UTC
That fixed it.

Now I wonder how it got screwed up. This was a fresh install from an rsync'd beta tree.

I did a yum update from 17->18 on another box and this didn't happen. Very weird.

Feel free to close it out if there are no other reports of it happening.

Comment 4 Kevin Fenzi 2012-11-30 22:06:08 UTC
Might be an anaconda bug on new installs... but I guess we can reopen if more folks see it.


Note You need to log in before you can comment on or make changes to this bug.