Bug 881569 - [ALL LANG][SAM Web GUI] Unexpected error: Couldn't find Organization with ID=1 [WHERE "organizations"."task_id" IS NULL] occurred when failed deletion for the default org 'ACME_Corporation'.
[ALL LANG][SAM Web GUI] Unexpected error: Couldn't find Organization with ID=...
Status: CLOSED DUPLICATE of bug 881568
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-11-29 01:16 EST by Lijun Li
Modified: 2012-11-29 08:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 01:19:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lijun Li 2012-11-29 01:16:36 EST
Description of problem:
Unexpected error: Couldn't find Organization with ID=1 [WHERE "organizations"."task_id" IS NULL] occurred when failed deletion for the default org 'ACME_Corporation'.

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
1. Create a user and assign the default Organization 'ACME_Corporation' to it.
2. Delete the default Organization 'ACME_Corporation'.
3. Back to user name list, click on the user name that assigned to the default Organization 'ACME_Corporation' in step 1, click on Environment sub tab.

  
Actual results:
1. After failed deletion for the default org 'ACME_Corporation'. Pops-up the following message and cannot create the org 'ACME_Corporation' again:
Organization 'ACME_Corporation' already exists and either has been scheduled for deletion or failed deletion. 

2. Unexpected error: Couldn't find Organization with ID=1 [WHERE "organizations"."task_id" IS NULL] occurred when failed deletion for the default org 'ACME_Corporation'.

3. The default org 'ACME_Corporation' failed deletion from the backend db. Only can create the org 'ACME_Corporation' again on the WEB GUI & CLI after deleting the record from db by manual:

# LANG=en_US.UTF-8 psql -d katelloschema -U katellouser

Password for user katellouser:

psql (8.4.13)

Type "help" for help.

 

katelloschema-> \dt organizations

              List of relations

Schema |     Name      | Type  |    Owner   

--------+---------------+-------+-------------

public | organizations | table | katellouser

(1 row)

 

katelloschema=> SELECT * FROM organizations;

id |       name       |          description          |                label     

           |         created_at         |         updated_at         | task_id | sy

stem_info_keys

----+------------------+-------------------------------+---------------------------

-----------+----------------------------+----------------------------+---------+---

---------------

  8 | test-org-pt      | test purpose                  | test-org-pt              

           | 2012-11-16 09:13:07.483353 | 2012-11-16 09:13:07.483353 |         | --

- []


  1 | ACME_Corporation | ACME_Corporation Organization | ACME_Corporation         

           | 2012-11-14 08:57:53.75969  | 2012-11-28 07:15:24.235321 |      73 | --

- []


katelloschema=> DELETE FROM organizations WHERE name='ACME_Corporation';

DELETE 1

Expected results:
1. No scuh unexpected error.
2. The default org 'ACME_Corporation' should be deleted from Web GUI and DB successfully.

Additional info:
Comment 1 Lijun Li 2012-11-29 01:19:43 EST

*** This bug has been marked as a duplicate of bug 881568 ***

Note You need to log in before you can comment on or make changes to this bug.