Bug 88158 - httpd / mysql / php / gzip problem with MS Internet Explorer 6 and windows 2k
httpd / mysql / php / gzip problem with MS Internet Explorer 6 and windows 2k
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-04-07 03:30 EDT by Patrick Oberli
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-01-25 11:46:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
httpd.conf (35.32 KB, text/plain)
2003-04-08 02:29 EDT, Patrick Oberli
no flags Details
php.ini (30.63 KB, text/plain)
2003-04-08 02:30 EDT, Patrick Oberli
no flags Details

  None (edit)
Description Patrick Oberli 2003-04-07 03:30:31 EDT
Components maybe envolved:
httpd-2.0.40-11  mysql-server-3.23.54a-4  php-4.2.2-8.0.7  gzip-1.3.3-5

I installed a redhat 8 on a dell poweredge 2300 server. 
it should show a website with php and mysql in the background (postnuke). the 
problem is now, if i wan't to browse the database on my local machine (windows 
2000 sp3 with all hotfixes and as browser internet explorer 6), i can't browse 
tables with more than about 15-20 entries. i tried also phpMyAdmin to browse 
tables, but as soon they got more than about 15 entries, the browser doesn't 
make anything.
i checked the whole thing with a packetsniffer on my win2k box and saw that i 
recieve packets if i click on browse, but the browser does nothing. i also 
testet it with netscape 7 and there it works without a problem, it also works 
on a NT4 with IE 5.5 installation. i testet the installation also on a second 
win2k sp3 machine with ie6 and there it also don't work. 
i'm not shure now where the problem really is, but i think it's a problem with 
the server and not with ie6. 
i couldn't see much in the sniffed packets, because they were compressed with 

i hope this is enough info


Every Time

Steps to Reproduce:
1. open webbrowser (ie6 on win2k sp3)
2. go on the website (for example in phpMyAdmin)
3. open a database
4. click on Browse on a table with more than about 15 entries
5. ie doesn't open the page

Actual Results:
the browser just stops and it looks like it's waiting on packets.

Expectet Results:
i can open the webpage.

Additional Information:
with wget on the local machine, i could open the page.
Comment 1 Joe Orton 2003-04-07 11:31:21 EDT
This sounds like a problem in either the PHP script or the database config.  I
suggest trying the mailing list for phpMyAdmin for more help.
Comment 2 Patrick Oberli 2003-04-07 11:43:47 EDT
This problem also occurs with postnuke, which has nothing to do with phpMyAdmin.
i think the problem is somewhere with the on the fly compression of the website.
is there a possible way to disable this "on-the-fly" compression? i couldn't 
find a hint about this in the httpd manual. 
disable the two lines:
AddEncoding x-compress Z
AddEncoding x-gzip gz tgz
didn't helped to disable it.

oh, i lowered also the priority.
Comment 3 Joe Orton 2003-04-07 11:49:26 EDT
Have you enabled PHP output compression in /etc/php.ini or elsewhere? It's off
by default.  Check for:

zlib.output_compression = Off

in /etc/php.ini.  Otherwise attach your httpd.conf and php.conf.
Comment 4 Patrick Oberli 2003-04-08 02:29:23 EDT
Created attachment 90991 [details]
Comment 5 Patrick Oberli 2003-04-08 02:30:28 EDT
Created attachment 90992 [details]
Comment 6 Patrick Oberli 2003-04-08 02:32:38 EDT
I checked the phpMyAdmin forum and I actually could find something (but no 
If you are interested in the thread, here you go:

- changed bug from NEEDINFO to ASSIGNED
Comment 7 Joe Orton 2003-04-08 03:55:54 EDT
Does it make a difference if you remove the "SetOutputFilter DEFLATE" statement
from your httpd.conf?
Comment 8 Patrick Oberli 2003-04-08 03:59:13 EDT
nope, no change.
Comment 9 Patrick Oberli 2003-04-09 02:44:19 EDT

I found the failure (at least in phpMyAdmin). I had to disable the OBGzip 
$cfg['OBGzip'] = FALSE;   // use GZIP output buffering if possible

With that phpMyAdmin works now. I'm not yet shure if that is a problem of 
phpMyAdmin or the server (gzip or something) but I'm posting this for your info.

Comment 10 Patrick Oberli 2003-04-09 02:50:06 EDT
small addition

after I disabled compression in postnuke it also works now. So I think it's a 
problem with a compression tool/library which has a bug and not the both tools.

Comment 11 Joe Orton 2003-04-09 03:49:53 EDT
Likely a problem in PHP's gzip output compression.
Comment 12 Patrick Oberli 2003-04-09 05:15:31 EDT
ah ok, so can we soon expect a php update on the redhat servers?
Comment 13 Joe Orton 2005-01-25 11:46:01 EST
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

c) report the bug to the Fedora Legacy project who may wish to
continue maintenance of this package.

Note You need to log in before you can comment on or make changes to this bug.