Bug 881588 - [de_DE][SAM Web GUI] - On the Add Permission page, the Text of the corresponding level going out of its boundary
[de_DE][SAM Web GUI] - On the Add Permission page, the Text of the correspond...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
All All
medium Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Katello Bug Bin
Katello QA List
: i18n, Translation, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-29 02:24 EST by Satyabrata Maitra
Modified: 2014-09-18 12:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:38:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen shot for de_DE role permission text not fitting. (41.93 KB, image/png)
2012-11-29 02:24 EST, Satyabrata Maitra
no flags Details

  None (edit)
Description Satyabrata Maitra 2012-11-29 02:24:27 EST
Created attachment 654022 [details]
screen shot for de_DE role permission text not fitting.

Description of problem:
in de_DE locale (German), on the Add Permission page, the Name of the Organization is going out of the level boundary, when the Organization name is a little big. I think, if we can make the level property a little dynamic with the length of the text entered, it should be ok because, many translated strings are long and already occupy the place, and along with those, if Org name also contains big strings, in that case, level property should be dynamic. Screen shot attached.

Version-Release number of selected component (if applicable):
katello-headpin-all-1.2.5-1h.el6_3
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
Always

Steps to Reproduce:
1. Login in SAM GUI, with Admin rights
2. Click on Roles, Administrator --> Roles
3. Create a New Role, clicking on the +New Role link
4. The page appears, soon after the new role created, Click on Permissions
5. From the Organizations List, Select an org, having a big name as shown in 
   the screen shot (ACME_Corporation)
6. Scroll down the page and click on Add Permission
7. Look at the Text " Add permission to <Organization_Name>

Actual results:
The Organization name is cutting from the end, due to the long translated strings that occupied most of the level space.

Expected results:
It should be fitted fully in the level boundary to enter texts.

Additional info: Screen shot attached.
Comment 1 Hedda Peters 2012-12-12 19:16:42 EST
Confirmed for de-DE. 
Unable to shorten the translation though, needs different solution.
Comment 2 Tom McKay 2012-12-18 13:09:40 EST
present in CFSE
Comment 4 Mike McCune 2014-03-18 13:38:33 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.