Bug 881614 - Set default block io scheduler
Summary: Set default block io scheduler
Keywords:
Status: CLOSED DUPLICATE of bug 870159
Alias: None
Product: ovirt-host-deploy
Classification: oVirt
Component: Plugins.tune
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Alon Bar-Lev
QA Contact: Pavel Stehlik
URL:
Whiteboard: Infra
Depends On: 754334 bootstrap-rewrite 878511
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-29 08:21 UTC by Alon Bar-Lev
Modified: 2015-09-20 19:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-03 17:34:45 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Alon Bar-Lev 2012-11-29 08:21:42 UTC
Up until now the default io scheduler was set in kernel arguments.
This is dangerous, intrusive, unportable and indeterministic.

bug#754334 added tuned dependency which should have done exactly this, but as it turns out (bug#878511) it does not applies the policy dynamically.

So we need some solution within vdsm or bootstrap. A solution for vdsm is available at[1].

But as tuned entered the picture it may be wiser to perform this at bootstrap level, dropping it when tuned is ready.

[1] http://gerrit.ovirt.org/#/c/8700/

Comment 1 Alon Bar-Lev 2012-12-03 17:34:45 UTC

*** This bug has been marked as a duplicate of bug 870159 ***


Note You need to log in before you can comment on or make changes to this bug.