Bug 88166 - cyrix m2 not booting after install
cyrix m2 not booting after install
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-07 06:40 EDT by randy smyth
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-08 10:49:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description randy smyth 2003-04-07 06:40:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
after the install redhat 9 will not boot but you aruldy knew that. i can go 
into rescue mode so it must be in the i686 calls somewhere. my system doesent 
get far enough to even genrate logs. the only way i can see to fix this is 
relese a i386 kernel and possable a i386 giblic. just like any other ver of 
redhat 8 and down always had a i386 included.

Version-Release number of selected component (if applicable):
redhat 9 kernel fresh off instal

How reproducible:
Always

Steps to Reproduce:
1. install redhat 9 on a cyrax m2

    

Actual Results:  system crash must hard shutdown.

Expected Results:  system to boot of course

Additional info:

my system is a cyrax m2 with a Delhi-3 mobo. 128 ram and a 32meg ati radion pci 
card. i knoe its old but if it can run M$ xp thers no reasion redhat 9 or other 
distros whont run.
Comment 1 Arjan van de Ven 2003-04-07 06:42:30 EDT
there IS an i586 kernel (and a i386 glibc) on the cd's.
Comment 2 randy smyth 2003-04-07 06:46:25 EDT
sorry i forgot to say i585 also is not working it thinks my prosser is a amd k6.
Comment 3 randy smyth 2003-04-07 06:48:52 EDT
sorry i forgot to say i585 also is not working it thinks my prosser is a amd k6.
Comment 4 randy smyth 2003-04-07 12:38:32 EDT
after some more messing around its defently in the i686 kernel my pc probly 
cant handel full calls cyrax are weard like that. the i586 thinks my pc is amd 
that didnt work welll eyther.

redhat defently needs to relese i386 kernel just like they did with all the 
other distros its the only way im going to get redhat 9 to work in my pc. or 
any other pc thats not 100% i686. hope this gets done soon i relly wanna get 
this working.
Comment 5 randy smyth 2003-04-15 17:50:50 EDT
i found my problem its defently in the i686 and i586 kernel. after rigging the 
i386 boot kernel it ran of course there was no networking or anything but it 
did its job and booted the system. so i am in need of a redhat 9 i386 kernel i 
still wonder why it wasent included in the first place. i hope you can get me 
one as soon as possable.
Comment 6 Andre Robatino 2003-05-18 14:28:05 EDT
  Presumably you're talking about an Emachines 333cs.  I have the same machine,
and for it to boot, APM has to be disabled.  There used to be code in the kernel
to disable APM automatically when a Delhi3 MB was detected, but it's been
removed in the 2.4.20 kernel.  This is probably the right decision, since not
everyone with a Delhi3 may have the problem, but it means that if you do, you
must disable it manually.  You can try appending the boot option "apm=off" at
boot time to verify that this works, then edit your lilo.conf or grub.conf to
make it permanent.
Comment 7 randy smyth 2003-05-18 16:00:51 EDT
yea i figured it out but being the bug was removed i never commentend that i 
fixed but apm=off worked just fine. 
Comment 8 Alan Cox 2003-06-08 10:49:31 EDT
Emachines BIOS problem if apm=off fixedit

Note You need to log in before you can comment on or make changes to this bug.