Bug 88169 - gvim forks on startup, causing numerous problems
gvim forks on startup, causing numerous problems
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks: 84794
  Show dependency treegraph
 
Reported: 2003-04-07 07:45 EDT by Martin Norback
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-07 08:22:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Norback 2003-04-07 07:45:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
WHen gvim starts up, it forks. This leads to problems when you've set gvim as
your EDITOR or VISUAL.

This is documented behavior, but it's still inconvenient, especially for a new
user, that doesn't know this.

The result is that a number of programs that use the EDITOR variable fail in
mysterious ways, because gvim forks, and the program thinks the editor is done.

Proposed fix:

Add
set guioptions+=f
to the system vimrc file that is shipped with Red Hat Linux. There are some
other good settings there already.

Version-Release number of selected component (if applicable):
vim-common-6.1-29

How reproducible:
Always

Steps to Reproduce:
1. Set EDITOR to gvim
2. Run a command that invokes EDITOR, for instance cvs commit    

Actual Results:  The commit fails with: "Log message unchanged or not specified"

Expected Results:  CVS should wait until the editor is done, but doesn't because
the editor forks.

Additional info:

I've contacted the maintainer of gvim, he said this is the desired behavior. I
disagree, if you really want gvim to fork on startup, you can use the standard
method and put an & after the command.
Comment 1 Karsten Hopp 2003-04-07 08:22:29 EDT
Other users are expecting this gvim behaviour from previous releases and I can't make the 
requested change to the vimrc and to the documentation. 
Please change your EDITOR setting to "gvim -f" or edit your 
/usr/share/vim/vim61/macros/vimrc if you want to change this for every user on your machine. 
Comment 2 Martin Norback 2003-04-07 08:42:58 EDT
Please reconsider, I can't think of one single occasion where the default
behavior is the best one. I know that a lot of users has been bitten by this bug
though.

I know how to fix it, so it's not a problem for me (anymore).

Now that more and more people use gvim, they are sure to fall into this bug.
Gvim is even a standard option in "Preferred programs", which sets the default
editor to "gvim", not "gvim -f".

If I get this fixed upstream, can you at least promise to let that change go
through?
Comment 3 Karsten Hopp 2003-04-07 08:52:48 EDT
I intend to stay as close as possible to the upstream version.  
If you manage to convince Bram Moldenaar to change this upstream, I'll include his patch. 

Note You need to log in before you can comment on or make changes to this bug.