Bug 881733 - "ip netns" sometimes fails with Stderr: 'mount of /sys failed: Device or resource busy\n'
"ip netns" sometimes fails with Stderr: 'mount of /sys failed: Device or reso...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: openstack-quantum (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bob Kukura
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-29 08:28 EST by Etsuji Nakai
Modified: 2014-02-27 18:17 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 08:22:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ad-hoc patch to ipnetns.c (1.48 KB, text/plain)
2012-11-29 08:28 EST, Etsuji Nakai
no flags Details
Alternative patch for quantum/agent/linux/utils.py (1.77 KB, patch)
2012-11-29 22:05 EST, Etsuji Nakai
no flags Details | Diff

  None (edit)
Description Etsuji Nakai 2012-11-29 08:28:02 EST
Created attachment 654286 [details]
ad-hoc patch to ipnetns.c

Description of problem:
When network namespace is enabled, dhcp-agent and l3-agent sometimes files to execute "ip netns" with the following error.

----
Command: ['sudo', 'quantum-rootwrap', '/etc/quantum/rootwrap.conf', 'ip', 'netns', 'exec', 'qdhcp-359fd226-4680-469c-84d1-bbe733c3e6ca', 'ip', 'link', 'set', 'tapa2491012-8e', 'up']
Exit code: 1
Stdout: ''
Stderr: 'mount of /sys failed: Device or resource busy\n'
----
Command: ['sudo', 'quantum-rootwrap', '/etc/quantum/rootwrap.conf', 'ip', 'netns', 'exec', 'qrouter-08ad50c6-4081-45f8-954d-b76595a8bcb9', 'sysctl', '-w', 'net.ipv4.ip_forward=1']
Exit code: 1
Stdout: ''
Stderr: 'mount of /sys failed: Device or resource busy\n'
----

Version-Release number of selected component (if applicable):
# rpm -qa |grep quantum
python-quantum-2012.2-1.fc18.noarch
openstack-quantum-openvswitch-2012.2-1.fc18.noarch
python-quantumclient-2.1.1-0.fc18.noarch
openstack-quantum-2012.2-1.fc18.noarch


Additional info:
As it looks depending on the timing of executing "ip netns", I added an ad-hoc patch to ip command as in the attached. It worked for me, at least, though there should be more fundamental fix.
Comment 1 Etsuji Nakai 2012-11-29 22:05:04 EST
Created attachment 654745 [details]
Alternative patch for quantum/agent/linux/utils.py

Instead of applying patch to ip, I tried another patch for quantum/agent/linux/utils.py. This worked for me, too.
Comment 2 Bob Kukura 2013-01-14 08:44:03 EST
This could be related to bug 882047.
Comment 3 Etsuji Nakai 2013-02-10 01:11:31 EST
Yes. In my setup, iproute-3.6.0-6.fc18 issued with #882047 resolved this, too.
Comment 4 Fedora End Of Life 2013-12-21 04:32:42 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2014-02-05 08:22:30 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.