Bug 881790 - (CVE-2012-5597, CVE-2012-6059) CVE-2012-5597 CVE-2012-6059 wireshark: DoS (crash) in the ISAKMP dissector (wnpa-sec-2012-35)
CVE-2012-5597 CVE-2012-6059 wireshark: DoS (crash) in the ISAKMP dissector (w...
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Product Security
impact=low,public=20121128,reported=2...
: Reopened, Security
Depends On: 881873 994924 1004712
Blocks: 881865 974906
  Show dependency treegraph
 
Reported: 2012-11-29 10:14 EST by Jan Lieskovsky
Modified: 2015-07-31 06:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 22:22:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Lieskovsky 2012-11-29 10:14:32 EST
An out of heap-based buffer bounds read flaw was found in the way Wireshark, a network traffic analyzer, performed dissection of certain ISAKMP packets. A remote attacker could provide a specially-crafted ISAKMP packet / packet capture that, when processed, would lead to wireshark executable crash.

Upstream bug report:
[1] https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=7855

References:
[2] http://www.wireshark.org/security/wnpa-sec-2012-35.html
[3] http://www.wireshark.org/docs/relnotes/wireshark-1.6.12.html
[4] http://www.wireshark.org/docs/relnotes/wireshark-1.8.4.html

Relevant upstream patch:
[5] http://anonsvn.wireshark.org/viewvc?view=revision&revision=45510

Reproducer:
[6] https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=7855#c1
Comment 1 Jan Lieskovsky 2012-11-29 10:17:45 EST
This issue did NOT affect the version of the wireshark package, as shipped with Red Hat Enterprise Linux 5.

--

This issue affects the version of the wireshark package, as shipped with Red Hat Enterprise Linux 6.

--

This issue affects the versions of the wireshark package, as shipped with Fedora release of 16 and 17.
Comment 2 Jan Lieskovsky 2012-11-29 12:51:15 EST
Created wireshark tracking bugs for this issue

Affects: fedora-all [bug 881873]
Comment 3 Vincent Danen 2012-11-29 17:07:15 EST
This was assigned CVE-2012-5597:

http://www.openwall.com/lists/oss-security/2012/11/29/5
Comment 11 Jan Lieskovsky 2012-12-05 08:46:03 EST
The CVE-2012-5597 identifier has been rejected by Mitre in favour of CVE-2012-6059 one:

Name: CVE-2012-5597

** REJECT **

DO NOT USE THIS CANDIDATE NUMBER.  ConsultIDs: CVE-2012-6059.  Reason:
This candidate is a reservation duplicate of CVE-2012-6059.  Notes:
All CVE users should reference CVE-2012-6059 instead of this
candidate.  All references and descriptions in this candidate have
been removed to prevent accidental usage.

--

The correct CVE identifier this particular wireshark flaw should be referenced under (from now on) is CVE-2012-6059.
Comment 12 errata-xmlrpc 2013-11-21 02:31:16 EST
This issue has been addressed in following products:

  Red Hat Enterprise Linux 6

Via RHSA-2013:1569 https://rhn.redhat.com/errata/RHSA-2013-1569.html
Comment 13 Huzaifa S. Sidhpurwala 2013-11-21 22:22:59 EST
Statement:

(none)

Note You need to log in before you can comment on or make changes to this bug.