Bug 881835 - setperms doesn't work
Summary: setperms doesn't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 18
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-29 16:37 UTC by brainkaraoke
Modified: 2013-01-12 01:03 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-12 01:03:46 UTC
Type: Bug


Attachments (Terms of Use)

Description brainkaraoke 2012-11-29 16:37:34 UTC
Description of problem:
When doing the command rpm --setperms on a package, it doesn't work. It gives an error message.


Version-Release number of selected component (if applicable):
4.10.1-3

How reproducible:
Do the command rpm --setperms

Steps to Reproduce:
1.rpm --setperms <some package>
  
Actual results:
error: incorrect format : invalid field width (translation from french)


Expected results:
It should fix the package file permissions

Comment 1 brainkaraoke 2012-11-30 04:32:33 UTC
It seems also that rpm doesn't put well permissions during install of new packets which prevents tools such as sudo or su to work out of the box (the setuid bit is not set). Because after an upgrade with fedup from f17 to f18, the permissions weren't set.

Comment 2 Panu Matilainen 2012-11-30 06:00:47 UTC
--setperms breakage confirmed, will fix.

Permissions not getting set on upgrade would be an entirely different issue however, --setperms is just dumb shell-glue that never gets invoked in normal operation. If you find a way to reproduce that, please open another bug for it.

Comment 3 Fedora Update System 2012-12-10 11:14:24 UTC
rpm-4.10.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rpm-4.10.2-1.fc18

Comment 4 Fedora Update System 2012-12-10 21:12:10 UTC
Package rpm-4.10.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpm-4.10.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20057/rpm-4.10.2-1.fc18
then log in and leave karma (feedback).

Comment 5 nuno ferreira 2012-12-12 22:31:15 UTC
I'm fc18-beta.
I have rpm-4.10.1-3.fc18.x86_64 and still this problem persists.
Thanks

Comment 6 Panu Matilainen 2012-12-13 07:01:09 UTC
(In reply to comment #5)
> I'm fc18-beta.
> I have rpm-4.10.1-3.fc18.x86_64 and still this problem persists.

Look at the information in comments 3-4 from the update system - it's not supposed to be fixed in what you have.

Comment 7 Jeff Raber 2013-01-07 19:12:57 UTC
I upgraded to F18 from F17 via fedup.  Post-upgrade, I followed the instructions here: http://fedorasolved.org/Members/fenris02/post_upgrade_cleanup and ended up with the 'oops... something bad happened' screen and could no longer logon graphically.

There were some messages in /var/log/messages that indicated a permission issue with the dbus servicehelper (/lib64/dbus-1/dbus-daemon-launch-helper).  'rpm --verify dbus' showed an issue with the permission of that file. 'rpm --setperms dbus' returned 'error: incorrect format : invalid field width'.  'yum reinstall dbus' fixed the permissions issue, but I know that there are a number of other binarys with the same issue (su, sudo).  

I suspect anyone following those post-upgrade instructions will run into this issue.

I have since updated rpm to version 4.10.2-1.fc18 (currently in updates-testing).  Afterwards, I ran 'rpm -a --setperms' and it seems to have fixed everything.

Excerpt from /var/log/messages (from when I was not able to logon graphically):

Jan  7 11:51:24 terid360100 dbus-daemon[557]: dbus[557]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Jan  7 11:51:24 terid360100 dbus[557]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Jan  7 11:51:24 terid360100 dbus-daemon[557]: dbus[557]: [system] Activated service 'net.reactivated.Fprint' failed: The permission of the setuid helper 
is not correct
Jan  7 11:51:24 terid360100 dbus[557]: [system] Activated service 'net.reactivated.Fprint' failed: The permission of the setuid helper is not correct
Jan  7 12:09:41 terid360100 dbus-daemon[557]: dbus[557]: [system] Activating service name='org.freedesktop.PackageKit' (using servicehelper)
Jan  7 12:09:41 terid360100 dbus[557]: [system] Activating service name='org.freedesktop.PackageKit' (using servicehelper)
Jan  7 12:09:41 terid360100 dbus-daemon[557]: dbus[557]: [system] Activated service 'org.freedesktop.PackageKit' failed: The permission of the setuid hel
per is not correct

Comment 8 Fedora Update System 2013-01-12 01:03:48 UTC
rpm-4.10.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.