Bug 881890 - freeipa: migration to /etc/hostname, /etc/vconsole.conf, /etc/locale.conf
freeipa: migration to /etc/hostname, /etc/vconsole.conf, /etc/locale.conf
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: freeipa (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rob Crittenden
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 881785
  Show dependency treegraph
 
Reported: 2012-11-29 13:22 EST by Michal Schmidt
Modified: 2012-12-11 19:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 19:28:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2012-11-29 13:22:22 EST
Fedora is migrating away from:
 /etc/sysconfig/network (the HOSTNAME=... setting)
 /etc/sysconfig/keyboard
 /etc/sysconfig/i18n
to:
 /etc/hostname
 /etc/vconsole.conf
 /etc/locale.conf

See the tracker bug 881785 for details.

We found:
freeipa-3.0.1/ipapython/platform/redhat.py edits HOSTNAME in /etc/sysconfig/network.

freeipa-3.0.1/ipa-client/ipa-install/ipa-client-install:        # configure /etc/sysconfig/network to contain the hostname we set.

Please update the package for the new config files.
Comment 1 Dmitri Pal 2012-11-29 22:26:57 EST
Please specify target release. I assume it is F19 not F18.
Comment 2 Michal Schmidt 2012-11-30 19:03:44 EST
F18, because the current situation in F18 is inconsistent. Some packages use the old files and some use the new ones. And there's a %post script in F18's systemd that migrates the old files to the new ones.
Comment 5 Martin Kosek 2012-12-03 04:44:41 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/3279
Comment 7 Fedora Update System 2012-12-10 15:34:34 EST
freeipa-3.1.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/freeipa-3.1.0-1.fc18
Comment 8 Fedora Update System 2012-12-11 00:02:53 EST
Package freeipa-3.1.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freeipa-3.1.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20123/freeipa-3.1.0-1.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-12-11 19:28:35 EST
freeipa-3.1.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.