This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 881962 - Project-wide S&R starts by Enter key before ready
Project-wide S&R starts by Enter key before ready
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity high
: ---
: 2.1
Assigned To: David Mason
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-29 16:30 EST by Yuko Katabami
Modified: 2013-02-25 23:06 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.1-SNAPSHOT (20121206-1113)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 23:06:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yuko Katabami 2012-11-29 16:30:40 EST
Description of problem:
When typing in Japanese, we have to convert phonetic input into appropriate characters by pressing space bar, then press Enter key to confirm. This is mostly done word by word, so if the search string consists of multiple words, search starts while converting the first word thus string is incomplete. There is no "Stop" button to stop this action either.

Version-Release number of selected component (if applicable): 2.0


How reproducible: Always


Steps to Reproduce:
1. Open a zanata project (ja-JP) and open Project-wide S&R
2. Using Japanese input method, type in "fairu", then press Space key to convert it into katakana characters "ファイル"
3. Press Enter to confirm the selection.

  
Actual results:
Search starts automatically without pressing "Search" button.

Expected results:
Search should not start without pressing "Search" button, so that we can complete inputting the rest of search string

Additional info:
Please also add "Stop" button.
Comment 1 Sean Flanigan 2012-11-29 20:18:10 EST
Please submit a separate RFE for the Stop button.  I assume you want it because the search takes a while to finish, and you can't do anything else in the meantime?

Once the search does finish, are you able to add the second word to your search?
Comment 2 Yuko Katabami 2012-11-29 20:25:34 EST
Yes, I can continue typing, but because the same action triggers the search, I am working around at the moment by typing the search string somewhere else or copying it and then past it on the search field. I will file a separate bug for the stop button as  you suggested. Yes, it is inconvenient because the search with wrong or incomplete keywords cannot be stop and sometimes it takes too long to finish. I cannot do anything until that is finished.
Comment 3 Ding-Yi Chen 2012-11-29 22:16:53 EST
Problem confirmed with ibus-anthy
Comment 4 Ding-Yi Chen 2012-11-29 22:51:57 EST
Further testing shows:

1. As expected behavior:
  a. Project Search
  b. Project wide S & R: Replace entry
  c. Translation Entry (With Enter key saves immediately ON) (Enter trigger save)

2. Input method Enter trigger excessive action
  a. Translation Memory search
  b. Glossary search
  c. Project wide S & R: Search entry


3. Enter does not trigger action at all (But it should)
 a.  Docucment page search (The search bar on the top of WebTran)
 b. Page number
Comment 5 Ding-Yi Chen 2012-11-29 23:30:46 EST
Also tested the Project S&R Search entry with ibus-chewing:
Use "5j/ jp6" (show as 中文)
The Enter key never triggger Search when ibus-chewing is activated.
Comment 6 David Mason 2012-12-05 20:07:37 EST
Fixed for TM search box, glossary search box and project-wide search box in 2.1-SNAPSHOT.

See: https://github.com/zanata/zanata/compare/79af82f1baa53271aea6c5384f48ae3c98d98d9e...34c13fe250ae243e4662920295fa419ec9dcac74
Comment 7 Ding-Yi Chen 2012-12-05 21:16:55 EST
VERIFIED with Zanata version 2.1-SNAPSHOT (20121206-1113),

Tested with ibus-chewing, ibus-anthy and ibus-pinyin.

Note You need to log in before you can comment on or make changes to this bug.