This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 881981 - [abrt] qemu-system-x86-1.2.0-23.fc18: crash in patch_hypercalls during autotest migration
[abrt] qemu-system-x86-1.2.0-23.fc18: crash in patch_hypercalls during autote...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
abrt_hash:63ddb84b06f411bf92b89db363a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-29 17:29 EST by Lucas Meneghel Rodrigues
Modified: 2015-10-18 18:41 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-15 09:28:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (90.38 KB, text/plain)
2012-11-29 17:29 EST, Lucas Meneghel Rodrigues
no flags Details
File: cgroup (126 bytes, text/plain)
2012-11-29 17:29 EST, Lucas Meneghel Rodrigues
no flags Details
File: core_backtrace (779 bytes, text/plain)
2012-11-29 17:29 EST, Lucas Meneghel Rodrigues
no flags Details
File: dso_list (7.98 KB, text/plain)
2012-11-29 17:29 EST, Lucas Meneghel Rodrigues
no flags Details
File: environ (3.93 KB, text/plain)
2012-11-29 17:29 EST, Lucas Meneghel Rodrigues
no flags Details
File: limits (1.29 KB, text/plain)
2012-11-29 17:29 EST, Lucas Meneghel Rodrigues
no flags Details
File: maps (40.95 KB, text/plain)
2012-11-29 17:29 EST, Lucas Meneghel Rodrigues
no flags Details
File: open_fds (7.03 KB, text/plain)
2012-11-29 17:29 EST, Lucas Meneghel Rodrigues
no flags Details
File: proc_pid_status (927 bytes, text/plain)
2012-11-29 17:29 EST, Lucas Meneghel Rodrigues
no flags Details
File: smolt_data (3.66 KB, text/plain)
2012-11-29 17:29 EST, Lucas Meneghel Rodrigues
no flags Details
File: var_log_messages (10.71 KB, text/plain)
2012-11-29 17:29 EST, Lucas Meneghel Rodrigues
no flags Details

  None (edit)
Description Lucas Meneghel Rodrigues 2012-11-29 17:29:25 EST
Description of problem:
I was running a migrate.with_reboot.tcp virt test, which migrates a guest during guest reboot. Command line:

18:59:28 INFO | Running qemu command (reformatted):
18:59:28 INFO | /usr/bin/qemu-kvm 
18:59:28 INFO |     -S 
18:59:28 INFO |     -name 'vm1' 
18:59:28 INFO |     -nodefaults 
18:59:28 INFO |     -chardev socket,id=hmp_id_hmp1,path=/tmp/monitor-hmp1-20121129-185926-qVBG0vep,server,nowait 
18:59:28 INFO |     -mon chardev=hmp_id_hmp1,mode=readline 
18:59:28 INFO |     -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20121129-185926-qVBG0vep,server,nowait 
18:59:28 INFO |     -device isa-serial,chardev=serial_id_serial1 
18:59:28 INFO |     -chardev socket,id=seabioslog_id_20121129-185926-qVBG0vep,path=/tmp/seabios-20121129-185926-qVBG0vep,server,nowait 
18:59:28 INFO |     -device isa-debugcon,chardev=seabioslog_id_20121129-185926-qVBG0vep,iobase=0x402 
18:59:28 INFO |     -device ich9-usb-uhci1,id=usb1 
18:59:28 INFO |     -drive file='/home/lmr/Code/virt-test.git/shared/data/images/jeos-17-64.qcow2',if=none,cache=none,id=virtio0 
18:59:28 INFO |     -device virtio-blk-pci,drive=virtio0 
18:59:28 INFO |     -device virtio-net-pci,netdev=idCA7g0t,mac='9a:9e:9f:a0:a1:a2',id='idXtpH3d' 
18:59:28 INFO |     -netdev user,id=idCA7g0t,hostfwd=tcp::5001-:22 
18:59:28 INFO |     -m 512 
18:59:28 INFO |     -smp 2,cores=1,threads=1,sockets=2 
18:59:28 INFO |     -cpu 'Penryn' 
18:59:28 INFO |     -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 
18:59:28 INFO |     -vnc :1 
18:59:28 INFO |     -vga std 
18:59:28 INFO |     -rtc base=utc,clock=host,driftfix=none  
18:59:28 INFO |     -boot order=cdn,once=c,menu=off  
18:59:28 INFO |     -enable-kvm 
18:59:28 INFO |     -incoming tcp:0:5200

After one migration completed successfully, we had a qemu segmentation fault.

Version-Release number of selected component:
qemu-system-x86-1.2.0-23.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/bin/qemu-kvm -S -name vm1 -nodefaults -chardev socket,id=hmp_id_hmp1,path=/tmp/monitor-hmp1-20121129-185926-qVBG0vep,server,nowait -mon chardev=hmp_id_hmp1,mode=readline -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20121129-185926-qVBG0vep,server,nowait -device isa-serial,chardev=serial_id_serial1 -chardev socket,id=seabioslog_id_20121129-185926-qVBG0vep,path=/tmp/seabios-20121129-185926-qVBG0vep,server,nowait -device isa-debugcon,chardev=seabioslog_id_20121129-185926-qVBG0vep,iobase=0x402 -device ich9-usb-uhci1,id=usb1 -drive file=/home/lmr/Code/virt-test.git/shared/data/images/jeos-17-64.qcow2,if=none,cache=none,id=virtio0 -device virtio-blk-pci,drive=virtio0 -device virtio-net-pci,netdev=idCA7g0t,mac=9a:9e:9f:a0:a1:a2,id=idXtpH3d -netdev user,id=idCA7g0t,hostfwd=tcp::5001-:22 -m 512 -smp 2,cores=1,threads=1,sockets=2 -cpu Penryn -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 -vnc :1 -vga std -rtc base=utc,clock=host,driftfix=none -boot order=cdn,once=c,menu=off -enable-kvm -incoming tcp:0:5200
crash_function: __memcmp_sse4_1
executable:     /usr/bin/qemu-kvm
kernel:         3.6.7-5.fc18.x86_64
remote_result:  NOTFOUND
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 __memcmp_sse4_1 at ../sysdeps/x86_64/multiarch/memcmp-sse4.S:1015
 #1 patch_hypercalls at /usr/src/debug/qemu-kvm-1.2.0/hw/kvmvapic.c:532
 #2 vapic_prepare at /usr/src/debug/qemu-kvm-1.2.0/hw/kvmvapic.c:597
 #3 vapic_post_load at /usr/src/debug/qemu-kvm-1.2.0/hw/kvmvapic.c:714
 #4 vmstate_load_state at /usr/src/debug/qemu-kvm-1.2.0/savevm.c:1458
 #5 vmstate_load at /usr/src/debug/qemu-kvm-1.2.0/savevm.c:1521
 #6 qemu_loadvm_state at /usr/src/debug/qemu-kvm-1.2.0/savevm.c:1965
 #7 process_incoming_migration at migration.c:91
 #8 tcp_accept_incoming_migration at migration-tcp.c:113
 #9 qemu_iohandler_poll at iohandler.c:159
Comment 1 Lucas Meneghel Rodrigues 2012-11-29 17:29:30 EST
Created attachment 654618 [details]
File: backtrace
Comment 2 Lucas Meneghel Rodrigues 2012-11-29 17:29:32 EST
Created attachment 654619 [details]
File: cgroup
Comment 3 Lucas Meneghel Rodrigues 2012-11-29 17:29:34 EST
Created attachment 654620 [details]
File: core_backtrace
Comment 4 Lucas Meneghel Rodrigues 2012-11-29 17:29:36 EST
Created attachment 654621 [details]
File: dso_list
Comment 5 Lucas Meneghel Rodrigues 2012-11-29 17:29:38 EST
Created attachment 654622 [details]
File: environ
Comment 6 Lucas Meneghel Rodrigues 2012-11-29 17:29:41 EST
Created attachment 654623 [details]
File: limits
Comment 7 Lucas Meneghel Rodrigues 2012-11-29 17:29:43 EST
Created attachment 654624 [details]
File: maps
Comment 8 Lucas Meneghel Rodrigues 2012-11-29 17:29:46 EST
Created attachment 654625 [details]
File: open_fds
Comment 9 Lucas Meneghel Rodrigues 2012-11-29 17:29:48 EST
Created attachment 654626 [details]
File: proc_pid_status
Comment 10 Lucas Meneghel Rodrigues 2012-11-29 17:29:50 EST
Created attachment 654627 [details]
File: smolt_data
Comment 11 Lucas Meneghel Rodrigues 2012-11-29 17:29:52 EST
Created attachment 654628 [details]
File: var_log_messages
Comment 12 Lucas Meneghel Rodrigues 2012-12-11 22:34:58 EST
I was running the virt test case migrate.with_reboot.exec, the problem happened right after the migration:

01:18:38 INFO | Migration completed successfully
01:18:41 INFO | [qemu output] /bin/sh: line 1:  5652 Segmentation fault      (core dumped) /bin/qemu-kvm -S -name 'vm1' -nodefaults -chardev socket,id=hmp_id_hmp1,path=/tmp/monitor-hmp1-20121212-011834-kk4NObHt,server,nowait -mon chardev=hmp_id_hmp1,mode=readline -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20121212-011834-kk4NObHt,server,nowait -device isa-serial,chardev=serial_id_serial1 -chardev socket,id=seabioslog_id_20121212-011834-kk4NObHt,path=/tmp/seabios-20121212-011834-kk4NObHt,server,nowait -device isa-debugcon,chardev=seabioslog_id_20121212-011834-kk4NObHt,iobase=0x402 -device ich9-usb-uhci1,id=usb1 -drive file='/home/lmr/Code/virt-test.git/shared/data/images/jeos-17-64.qcow2',if=none,id=virtio0 -device virtio-blk-pci,drive=virtio0,bootindex=1 -device virtio-net-pci,netdev=idnrNhyE,mac='9a:65:66:67:68:69',id='id76AwKp' -netdev user,id=idnrNhyE,hostfwd=tcp::5000-:22 -m 512 -smp 2,cores=1,threads=1,sockets=2 -cpu 'SandyBridge' -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 -vnc :1 -vga std -rtc base=utc,clock=host,driftfix=none -boot order=cdn,once=c,menu=off -enable-kvm -incoming "exec:nc -l 5200"
01:18:41 INFO | [qemu output] (Process terminated with status 139)


backtrace_rating: 4
Package: qemu-system-x86-1.2.0-24.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 13 Cole Robinson 2012-12-14 17:45:54 EST
Juan, Paolo, any thoughts?
Comment 14 Cole Robinson 2013-01-14 20:18:21 EST
Lucas, have you seen this since the update to qemu 1.2.2 in F18?
Comment 15 Lucas Meneghel Rodrigues 2013-01-15 08:36:53 EST
I've just tried the test again and it did not crash with qemu-kvm-1.2.2-1.fc18.x86_64. The problem is solved with this new version.
Comment 16 Cole Robinson 2013-01-15 09:28:52 EST
Thanks Lucas, closing.

Note You need to log in before you can comment on or make changes to this bug.