Bug 881989 - [PATCH] for uint64 values on i386
[PATCH] for uint64 values on i386
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-lvm (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andy Grover
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-29 17:34 EST by James Antill
Modified: 2012-12-05 19:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-05 19:36:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for using buildvalud("K") instead of buildvalue("l") for lvm sizes (3.96 KB, patch)
2012-11-29 17:34 EST, James Antill
no flags Details | Diff
New version of buildvalue patch without the helper (3.74 KB, patch)
2012-11-30 09:34 EST, James Antill
no flags Details | Diff

  None (edit)
Description James Antill 2012-11-29 17:34:43 EST
Created attachment 654641 [details]
patch for using buildvalud("K") instead of buildvalue("l") for lvm sizes

Description of problem:

 LVM sizes are in uint64_t, python-lvm currently specifies "l" which is (long) ... this is very bad on i386 due to buildvalue being varargs. Patch attached and at:

http://james.fedorapeople.org/patches/build-value.patch

...added helper function, due to the needed cast.

 Also the F17 python-lvm just segfaults, and I have to hack patch out lvm_config_find_bool to make the F18 python-lvm work on F17 ... so would it be possible to release an official rebased python-lvm on F17?
Comment 1 Andy Grover 2012-11-29 19:31:10 EST
Nice catch.

I'd be slightly happier with the casts in all the callsites rather than the helper function, I think. Any objections?

Regarding F17, sorry about that. I'll get on it.

BTW please note that python-lvm is now part of lvm2 proper, so the separate src pkg will be going away.
Comment 2 James Antill 2012-11-30 09:34:21 EST
Created attachment 655083 [details]
New version of buildvalue patch without the helper

 No problem, here is a new version of the patch without the helper.
Comment 3 Andy Grover 2012-12-05 19:36:28 EST
Applied to lvm2 and python-lvm repos. Thanks again!

Note You need to log in before you can comment on or make changes to this bug.