Bug 882035 - [abrt] eclipse-pydev-2.7.1-1.fc17: interpreterInfo.py:199:<module>:RuntimeError: Ok, this is so that it shows the output (ugly hack for some platforms, so that it releases the output).
Summary: [abrt] eclipse-pydev-2.7.1-1.fc17: interpreterInfo.py:199:<module>:RuntimeErr...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-pydev
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sami Wagiaalla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:cd93378f8f709fd555d730d0f44...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-30 00:37 UTC by Joel Goguen
Modified: 2016-06-07 22:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-13 05:53:09 UTC
Type: ---


Attachments (Terms of Use)
File: executable (107 bytes, text/plain)
2012-11-30 00:37 UTC, Joel Goguen
no flags Details
File: environ (1.52 KB, text/plain)
2012-11-30 00:37 UTC, Joel Goguen
no flags Details
File: smolt_data (3.18 KB, text/plain)
2012-11-30 00:37 UTC, Joel Goguen
no flags Details
File: backtrace (7.58 KB, text/plain)
2012-11-30 00:37 UTC, Joel Goguen
no flags Details
File: core_backtrace (164 bytes, text/plain)
2012-11-30 00:37 UTC, Joel Goguen
no flags Details

Description Joel Goguen 2012-11-30 00:37:31 UTC
Description of problem:
In Eclipse, used Auto-Configure to locate Python interpreters.

Version-Release number of selected component:
eclipse-pydev-2.7.1-1.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
cmdline:        /usr/bin/python2.7 -u /usr/share/eclipse/dropins/pydev/eclipse/plugins/org.python.pydev_2.7.1.2012100913/pysrc/interpreterInfo.py
kernel:         3.6.7-4.fc17.x86_64

Comment 1 Joel Goguen 2012-11-30 00:37:34 UTC
Created attachment 654676 [details]
File: executable

Comment 2 Joel Goguen 2012-11-30 00:37:35 UTC
Created attachment 654677 [details]
File: environ

Comment 3 Joel Goguen 2012-11-30 00:37:37 UTC
Created attachment 654678 [details]
File: smolt_data

Comment 4 Joel Goguen 2012-11-30 00:37:39 UTC
Created attachment 654679 [details]
File: backtrace

Comment 5 Joel Goguen 2012-11-30 00:37:40 UTC
Created attachment 654680 [details]
File: core_backtrace

Comment 6 Alexander Kurtakov 2012-11-30 08:44:02 UTC
Sami, please care of this one. We used to have a patch removing this throw but it seems it was lost in some version upgrade. Git history will help you find what was done.

Comment 7 Fedora Update System 2012-12-04 21:42:08 UTC
eclipse-pydev-2.7.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/eclipse-pydev-2.7.1-2.fc18

Comment 8 Fedora Update System 2012-12-04 21:44:15 UTC
eclipse-pydev-2.7.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/eclipse-pydev-2.7.1-2.fc17

Comment 9 Fedora Update System 2012-12-05 06:56:30 UTC
Package eclipse-pydev-2.7.1-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-pydev-2.7.1-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19725/eclipse-pydev-2.7.1-2.fc17
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2012-12-13 05:53:11 UTC
eclipse-pydev-2.7.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-01-12 00:48:52 UTC
eclipse-pydev-2.7.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.