Bug 882050 - Attach 24 usb-storage device to windows guest, sometimes after reboot one disk can not be used with error "device cannot start"
Summary: Attach 24 usb-storage device to windows guest, sometimes after reboot one dis...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-30 02:27 UTC by Shaolong Hu
Modified: 2014-06-10 07:28 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-25 09:35:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
error device cannot start (98.45 KB, image/png)
2012-11-30 02:27 UTC, Shaolong Hu
no flags Details

Description Shaolong Hu 2012-11-30 02:27:21 UTC
Created attachment 654707 [details]
error device cannot start

Description of problem:
------------------------
Attach 24 usb-storage device to windows guest, sometimes after reboot one disk can not be used with error "device cannot start".


Version-Release number of selected component (if applicable):
--------------------------------------------------------------
qemu-kvm-rhev-0.12.1.2-2.331.el6.x86_64
guest: win7-64

How reproducible:
------------------
50%


Steps to Reproduce:
--------------------
1. boot guest with 24 usb storage
2. reboot guest repeatedly, check device manager, sometimes one disk with error "device cannot start", see screenshot in attachment.


Additional info:
-----------------
I test 6 usb-storage on one echi controller, won't hit this problem, so the number of usb-storage does have matter.


CMD:

/usr/libexec/qemu-kvm \
-name vm1 \
-chardev socket,id=qmp_monitor_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20120417-201603-0CS2,server,nowait \
-mon chardev=qmp_monitor_id_qmpmonitor1,mode=control \
-chardev socket,id=serial_id_20120417-201603-0CS2,path=/tmp/serial-20120417-201603-0CS2,server,nowait \
-device isa-serial,chardev=serial_id_20120417-201603-0CS2 \
-device usb-ehci,id=usb1,bus=pci.0,addr=0x4 \
-device usb-ehci,id=usb2,bus=pci.0,addr=0x5 \
-device usb-ehci,id=usb3,bus=pci.0,addr=0x6 \
-device usb-ehci,id=usb4,bus=pci.0,addr=0x7 \
-drive file=nfs/win7-64-virtio.qcow2,index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,boot=on,snapshot=off,readonly=off,format=qcow2,aio=native \
-device virtio-blk-pci,bus=pci.0,addr=0x8,drive=drive-virtio-disk1,id=virtio-disk1 \
-drive file=disk1,if=none,id=usb2.0,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb1.0,port=1,drive=usb2.0 \
-drive file=disk2,if=none,id=usb2.1,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb1.0,port=2,drive=usb2.1 \
-drive file=disk3,if=none,id=usb2.2,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb1.0,port=3,drive=usb2.2 \
-drive file=disk4,if=none,id=usb2.3,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb1.0,port=4,drive=usb2.3 \
-drive file=disk5,if=none,id=usb2.4,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb1.0,port=5,drive=usb2.4 \
-drive file=disk6,if=none,id=usb2.5,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb1.0,port=6,drive=usb2.5 \
-drive file=disk7,if=none,id=usb2.6,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb2.0,port=1,drive=usb2.6 \
-drive file=disk8,if=none,id=usb2.7,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb2.0,port=2,drive=usb2.7 \
-drive file=disk9,if=none,id=usb2.8,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb2.0,port=3,drive=usb2.8 \
-drive file=disk10,if=none,id=usb2.9,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb2.0,port=4,drive=usb2.9 \
-drive file=disk11,if=none,id=usb2.10,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb2.0,port=5,drive=usb2.10 \
-drive file=disk12,if=none,id=usb2.11,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb2.0,port=6,drive=usb2.11 \
-drive file=disk13,if=none,id=usb2.12,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb3.0,port=1,drive=usb2.12 \
-drive file=disk14,if=none,id=usb2.13,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb3.0,port=2,drive=usb2.13 \
-drive file=disk15,if=none,id=usb2.14,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb3.0,port=3,drive=usb2.14 \
-drive file=disk16,if=none,id=usb2.15,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb3.0,port=4,drive=usb2.15 \
-drive file=disk17,if=none,id=usb2.16,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb3.0,port=5,drive=usb2.16 \
-drive file=disk18,if=none,id=usb2.17,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb3.0,port=6,drive=usb2.17 \
-drive file=disk19,if=none,id=usb2.18,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb4.0,port=1,drive=usb2.18 \
-drive file=disk20,if=none,id=usb2.19,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb4.0,port=2,drive=usb2.19 \
-drive file=disk21,if=none,id=usb2.20,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb4.0,port=3,drive=usb2.20 \
-drive file=disk22,if=none,id=usb2.21,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb4.0,port=4,drive=usb2.21 \
-drive file=disk23,if=none,id=usb2.22,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb4.0,port=5,drive=usb2.22 \
-drive file=disk24,if=none,id=usb2.23,media=disk,cache=none,boot=off,snapshot=off,readonly=off,format=qcow2,aio=native \
-device usb-storage,bus=usb4.0,port=6,drive=usb2.23 \
-m 4096 \
-smp 2,cores=1,threads=1,sockets=2 \
-rtc base=localtime,clock=host,driftfix=slew \
-M rhel6.3.0 \
-boot order=cdn,once=c,menu=off   \
-enable-kvm \
-vnc :10 \
-monitor stdio

Comment 3 Ronen Hod 2013-05-26 16:14:58 UTC
How is the CPU doing? Could this be the issue?
Bug 949547 - qemu-kvm process consumes 8% cpu even when windows guest is idle inside and 70% when guest uses 10% cpu inside
Is a Linux guest any better?
Deferring to RHEL6.6, since supporting 24 USB disks inside a Win guest is probably not high priority.

Comment 4 Ronen Hod 2013-07-25 09:35:56 UTC
Closing.
Unlikely to be fixed in RHEL6.
Please test with RHEL7, and file a new BZ

Comment 5 juzhang 2014-06-10 02:21:30 UTC
(In reply to Ronen Hod from comment #4)
> Closing.
> Unlikely to be fixed in RHEL6.
> Please test with RHEL7, and file a new BZ

Seems we missed this needinfo before.

Can we have a test and update the testing result in the bz?

Best Regards,
Junyi

Comment 6 Shaolong Hu 2014-06-10 07:28:51 UTC
(In reply to juzhang from comment #5)
> (In reply to Ronen Hod from comment #4)
> > Closing.
> > Unlikely to be fixed in RHEL6.
> > Please test with RHEL7, and file a new BZ
> 
> Seems we missed this needinfo before.
> 
> Can we have a test and update the testing result in the bz?
> 
> Best Regards,
> Junyi

Test several times, there is one time that one of 24 usb storage shows "!" in device manager after guest boots, but after "disable"/"enable", it starts correctly, so the situation is better now though has some minor issue.


Note You need to log in before you can comment on or make changes to this bug.