Bug 882059 - Switching via Ctrl Alt FX sometimes causes loss of video output
Switching via Ctrl Alt FX sometimes causes loss of video output
Status: CLOSED DUPLICATE of bug 849347
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-29 22:24 EST by Jon Dufresne
Modified: 2013-01-26 14:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-26 14:36:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (46.90 KB, text/x-log)
2012-11-29 22:24 EST, Jon Dufresne
no flags Details

  None (edit)
Description Jon Dufresne 2012-11-29 22:24:56 EST
Created attachment 654748 [details]
Xorg log

Description of problem:
There are normally two users logged into GNOME 3 simultaneously. Switching between these two users using Ctrl + Alt + FX will sometimes cause the display to go black. When this happens, the monitor displays "no signal going to sleep". It appears as there is no video signal. This does not happen with every switch, but frequently enough to happen daily. Once this occurs, I am unable to recover the video without a restart.

Version-Release number of selected component (if applicable):
Kernel 3.6.7-5.fc18.x86_64
xorg-x11-drv-wacom-0.16.1-2.fc18.x86_64
xorg-x11-xinit-1.3.2-7.fc18.x86_64
xorg-x11-drv-qxl-0.1.0-1.fc18.x86_64
xorg-x11-server-utils-7.5-14.fc18.x86_64
xorg-x11-server-Xorg-1.13.0-10.fc18.x86_64
xorg-x11-drv-nouveau-1.0.4-1.fc18.x86_64
xorg-x11-drv-ati-7.0.0-0.8.20121015gitbd9e2c064.fc18.x86_64
xorg-x11-xkb-utils-7.7-4.fc18.x86_64
xorg-x11-server-common-1.13.0-10.fc18.x86_64
xorg-x11-drv-synaptics-1.6.2-7.fc18.x86_64
xorg-x11-utils-7.5-7.fc18.x86_64
xorg-x11-drv-openchrome-0.3.1-1.fc18.x86_64
xorg-x11-drv-mga-1.6.1-2.fc18.x86_64
xorg-x11-font-utils-7.5-9.fc18.x86_64
xorg-x11-drv-vmware-12.0.2-3.20120718gite5ac80d8f.fc18.x86_64
xorg-x11-drv-vmmouse-12.9.0-7.fc18.x86_64
xorg-x11-drv-intel-2.20.14-1.fc18.x86_64
xorg-x11-drv-vesa-2.3.2-2.fc18.x86_64
xorg-x11-xauth-1.0.7-2.fc18.x86_64
xorg-x11-drv-fbdev-0.4.3-3.fc18.x86_64
xorg-x11-drv-evdev-2.7.3-2.fc18.x86_64
xorg-x11-drv-modesetting-0.4.0-4.fc18.x86_64
Comment 1 Jon Dufresne 2012-12-04 15:27:13 EST
This is worse than I originally thought. It happens when using GNOME's menu to switch user in addition to the Ctrl + Alt + FX keys. The kernel does not crash as I can continue communicating with the computer over the network. This makes a multi user desktop unusable in any practical way. For that reason I am bumping the severity. I believe this bug is triggered during KMS switching.
Comment 2 Michael Schwendt 2012-12-21 13:40:22 EST
This has been mentioned on test list a few days ago. Happens for me with an up-to-date F18, too. Sometimes the switch to virtual console succeeds, in other cases the screen turns black, monitor loses signal, and repeated attempts to switch back and forth don't fix that.

[...]

Xorg.0.log only mentions:

[  2100.836] (II) AIGLX: Suspending AIGLX clients for VT switch
[  2101.371] (II) AIGLX: Resuming AIGLX clients after VT switch

There is a flood of log messages afterwards (this block of lines a few times per second):

Dec 21 19:11:11 noname kernel: [ 2101.372110] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation -35!
Dec 21 19:11:11 noname kernel: [ 2101.373627] radeon 0000:01:00.0: GPU reset succeeded, trying to resume
Dec 21 19:11:11 noname kernel: [ 2101.375646] [drm] probing gen 2 caps for device 8086:2e21 = 2/0
Dec 21 19:11:11 noname kernel: [ 2101.375650] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
Dec 21 19:11:11 noname kernel: [ 2101.378011] [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
Dec 21 19:11:11 noname kernel: [ 2101.378062] radeon 0000:01:00.0: WB enabled
Dec 21 19:11:11 noname kernel: [ 2101.378067] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000010000c00 and cpu addr 0xffff880134f62c00
Dec 21 19:11:11 noname kernel: [ 2101.410401] [drm] ring test on 0 succeeded in 1 usecs
Dec 21 19:11:11 noname kernel: [ 2101.613055] [drm] ib test on ring 0 succeeded in 0 usecs
Comment 3 Jean-François Fortin Tam 2013-01-25 22:14:32 EST
This is basically the same thing as bug #849347 bug #646199 bug #883536 ; see also upstream at https://bugs.freedesktop.org/show_bug.cgi?id=54133
Comment 4 Jon Dufresne 2013-01-26 14:36:54 EST

*** This bug has been marked as a duplicate of bug 849347 ***

Note You need to log in before you can comment on or make changes to this bug.