Bug 882086 - Test case failure: Direct Rendering - glxinfo on AMD 7700M nee ATI Device [1002:682d]
Summary: Test case failure: Direct Rendering - glxinfo on AMD 7700M nee ATI Device [10...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-ati
Version: 6.4
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jérôme Glisse
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-30 04:49 UTC by Vasiliy Sharapov
Modified: 2015-09-09 10:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Use hardware acceleration for OpenGL on Southern Island family of GPU. Reason: Result (if any):
Clone Of:
Environment:
Last Closed: 2013-11-21 10:08:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1597 normal SHIPPED_LIVE xorg-x11-drv-ati bug fix and enhancement update 2013-11-21 00:40:13 UTC

Description Vasiliy Sharapov 2012-11-30 04:49:09 UTC
Filed from caserun https://tcms.engineering.redhat.com/run/52108/#caserun_1859323

Version-Release number of selected component (if applicable):
RHEL6.4-20121120.n.0

Steps to Reproduce: 
 1. Determine if direct rendering is supported on the video chipset you are
    currently using. If it is not, remove this case from your test run. Note:
    drm module can be loaded for use of 2d acceleration while 3d (DRI) is not
    enabled.
 2. Open a terminal


 1. Execute 'glxinfo | grep render'



Actual results: 
Returns "OpenGL renderer string: Software Rasterizer"

Expected results:
That the output is direct rendering: Yes and also that it does NOT return 
OpenGL renderer string: Software Rasterizer only for ati and intel.

For nouveau sw rasreriser is an expected behavior.

Comment 2 Jérôme Glisse 2012-11-30 16:52:07 UTC
Expected, hw acceleration will be in rhel 6.5 or rhel 7.1, if upstream is working properly in time.

Comment 3 RHEL Product and Program Management 2012-12-14 08:31:12 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 Jérôme Glisse 2013-07-16 22:00:24 UTC
Should work with RHEL6.5

Comment 6 Tomas Pelka 2013-09-19 12:43:14 UTC
Vasiliy please verify within the Radeon HD 7700 test run.

Thanks
Tom

Comment 9 errata-xmlrpc 2013-11-21 10:08:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1597.html


Note You need to log in before you can comment on or make changes to this bug.