Bug 882093 - [FEAT]v7's network should reflect the max real transfer rate/performace
Summary: [FEAT]v7's network should reflect the max real transfer rate/performace
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Retired
Component: Test Suite (tests)
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
: 882088 (view as bug list)
Depends On:
Blocks: 918226
TreeView+ depends on / blocked
 
Reported: 2012-11-30 05:14 UTC by QinXie
Modified: 2013-08-06 17:44 UTC (History)
5 users (show)

Fixed In Version: hwcert-client-1.6.4-R45
Doc Type: Enhancement
Doc Text:
Feature: NETWORK test in new hwcert-client changes the bandwidth portion of the TCP testing to try different parallelism settings: 2, 4, and 8 in and attempt to verify transmission at 80% of the interface speed. Reason: Result (if any): If this goal is not met, warning messages are logged. The test passes so long as bw_tcp does not produce errors.
Clone Of:
: 918226 (view as bug list)
Environment:
Last Closed: 2013-08-06 17:44:44 UTC


Attachments (Terms of Use)
network test patch to apply bandwidth goal to tcp bandwidth testing (5.28 KB, patch)
2013-04-09 14:13 UTC, Greg Nichols
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1139 0 normal SHIPPED_LIVE hwcert-client-1.6 bug fix and enhancement update 2013-08-06 21:42:43 UTC

Description QinXie 2012-11-30 05:14:22 UTC
In review process, one step is to check the real transfer rate. If it's much lower than the naming value, we will require vendor to explain the reason, and will ask vendor to run some manual tests. 

In cert#828100, v7 reports return value of bw_tcp is 400MBps:
<snip>
TCP latency using 10.0.0.10: 0.0940 microseconds
testing bandwidth to 10.0.0.10...
0.065536 408.99 MB/sec
</snip>

While vendor reports manual test of bw_tcp returns about 2.1GMBps, and iperf returns 27GBps. For detail, please refer to https://hardware.redhat.com/show.cgi?id=828100#c45
<snip>
[root@SA2260-X9DR3-LN4F ~]# bw_tcp -m 65520 -P 8 10.0.0.10
0.065520 2166.37 MB/sec
</snip>

Also, vendor provides manual step and config info in  https://hardware.redhat.com/show.cgi?id=828100#c47
<snip>
I did the following steps:
- set CONNECTED_MODE=yes and MTU=65520 in
/etc/sysconfig/network-scripts/ifcfg-ib0 (for both server and test system)
- set the governor to performance in /etc/sysconfig/cpuspeed
- bound the process qib_cq to a specific CPU core with 'taskset -pc 3 $(pidof
qib_cq)' on both server and client
</snip>

Wondering could the process of network test be improved to reflect max real transfer rate?

Comment 2 redhat-hwcert 2012-11-30 16:11:21 UTC
I want to add some remarks:
- To get a result near the maximum throughput it's best to have eight (8) parallel streams. I have also tested with lower and higher values but it figured out that the configuration based on eight streams shows the best performance.

- The taskset command is most useful when the defined CPU core belongs to the CPU that is providing the PCIe lanes for the Infiniband adapter (in my case QLE7340).

Best regards
Marcus Wiedemann

Comment 3 Caspar Zhang 2012-12-19 16:50:42 UTC
*** Bug 882088 has been marked as a duplicate of this bug. ***

Comment 5 Greg Nichols 2013-04-09 14:13:14 UTC
Created attachment 733253 [details]
network test patch to apply bandwidth goal to tcp bandwidth testing

The patch changes the bandwidth portion of the TCP testing to try different parallelism settings: 2, 4, and 8 in and attempt to verify transmission at 80% of the interface speed.

If this goal is not met, warning messages are logged.   The test passes so long as bw_tcp does not produce errors.

Comment 12 errata-xmlrpc 2013-08-06 17:44:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1139.html


Note You need to log in before you can comment on or make changes to this bug.