Bug 882100 - [abrt] geeqie-1.0-15.fc17: gray_find_cell: Process /usr/bin/geeqie was killed by signal 6 (SIGABRT)
[abrt] geeqie-1.0-15.fc17: gray_find_cell: Process /usr/bin/geeqie was killed...
Status: CLOSED DUPLICATE of bug 678397
Product: Fedora
Classification: Fedora
Component: geeqie (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Schwendt
Fedora Extras Quality Assurance
abrt_hash:32e23911473a82d9e99ca042382...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-30 00:42 EST by Egon Kastelijn
Modified: 2012-11-30 05:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 05:35:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (14.22 KB, text/plain)
2012-11-30 00:42 EST, Egon Kastelijn
no flags Details
File: environ (3.50 KB, text/plain)
2012-11-30 00:42 EST, Egon Kastelijn
no flags Details
File: limits (1.29 KB, text/plain)
2012-11-30 00:42 EST, Egon Kastelijn
no flags Details
File: backtrace (81.89 KB, text/plain)
2012-11-30 00:42 EST, Egon Kastelijn
no flags Details
File: smolt_data (3.30 KB, text/plain)
2012-11-30 00:42 EST, Egon Kastelijn
no flags Details
File: cgroup (127 bytes, text/plain)
2012-11-30 00:42 EST, Egon Kastelijn
no flags Details
File: executable (15 bytes, text/plain)
2012-11-30 00:42 EST, Egon Kastelijn
no flags Details
File: maps (35.13 KB, text/plain)
2012-11-30 00:42 EST, Egon Kastelijn
no flags Details
File: dso_list (6.56 KB, text/plain)
2012-11-30 00:43 EST, Egon Kastelijn
no flags Details
File: proc_pid_status (920 bytes, text/plain)
2012-11-30 00:43 EST, Egon Kastelijn
no flags Details
File: open_fds (266 bytes, text/plain)
2012-11-30 00:43 EST, Egon Kastelijn
no flags Details
File: var_log_messages (147 bytes, text/plain)
2012-11-30 00:43 EST, Egon Kastelijn
no flags Details
File: build_ids (2.72 KB, text/plain)
2012-11-30 00:43 EST, Egon Kastelijn
no flags Details

  None (edit)
Description Egon Kastelijn 2012-11-30 00:42:42 EST
Description of problem:
The first time I opened the SVG file with geeqie, geeqie crashed.
The second time (with the exact same command) it opened fine.


Version-Release number of selected component:
geeqie-1.0-15.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        geeqie weight.svg
crash_function: gray_find_cell
kernel:         3.6.7-4.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #6 gray_find_cell at /usr/src/debug/freetype-2.4.8/src/smooth/ftgrays.c:481
: #7 gray_record_cell at /usr/src/debug/freetype-2.4.8/src/smooth/ftgrays.c:501
: #9 gray_set_cell at /usr/src/debug/freetype-2.4.8/src/smooth/ftgrays.c:544
: #10 gray_render_scanline at /usr/src/debug/freetype-2.4.8/src/smooth/ftgrays.c:649
: #11 gray_render_line at /usr/src/debug/freetype-2.4.8/src/smooth/ftgrays.c:839
: #12 gray_render_cubic at /usr/src/debug/freetype-2.4.8/src/smooth/ftgrays.c:1100
: #13 gray_cubic_to at /usr/src/debug/freetype-2.4.8/src/smooth/ftgrays.c:1157
: #14 FT_Outline_Decompose at /usr/src/debug/freetype-2.4.8/src/base/ftoutln.c:252
: #15 gray_convert_glyph_inner at /usr/src/debug/freetype-2.4.8/src/smooth/ftgrays.c:1706
: #16 gray_convert_glyph at /usr/src/debug/freetype-2.4.8/src/smooth/ftgrays.c:1808
Comment 1 Egon Kastelijn 2012-11-30 00:42:45 EST
Created attachment 654830 [details]
File: core_backtrace
Comment 2 Egon Kastelijn 2012-11-30 00:42:47 EST
Created attachment 654831 [details]
File: environ
Comment 3 Egon Kastelijn 2012-11-30 00:42:48 EST
Created attachment 654832 [details]
File: limits
Comment 4 Egon Kastelijn 2012-11-30 00:42:51 EST
Created attachment 654833 [details]
File: backtrace
Comment 5 Egon Kastelijn 2012-11-30 00:42:53 EST
Created attachment 654834 [details]
File: smolt_data
Comment 6 Egon Kastelijn 2012-11-30 00:42:55 EST
Created attachment 654835 [details]
File: cgroup
Comment 7 Egon Kastelijn 2012-11-30 00:42:57 EST
Created attachment 654836 [details]
File: executable
Comment 8 Egon Kastelijn 2012-11-30 00:42:59 EST
Created attachment 654837 [details]
File: maps
Comment 9 Egon Kastelijn 2012-11-30 00:43:01 EST
Created attachment 654838 [details]
File: dso_list
Comment 10 Egon Kastelijn 2012-11-30 00:43:03 EST
Created attachment 654839 [details]
File: proc_pid_status
Comment 11 Egon Kastelijn 2012-11-30 00:43:05 EST
Created attachment 654840 [details]
File: open_fds
Comment 12 Egon Kastelijn 2012-11-30 00:43:07 EST
Created attachment 654841 [details]
File: var_log_messages
Comment 13 Egon Kastelijn 2012-11-30 00:43:09 EST
Created attachment 654842 [details]
File: build_ids
Comment 14 Michael Schwendt 2012-11-30 05:35:43 EST
It's not Geeqie that crashed, but libfreetype (package "freetype"). It was aborted by glibc ("longjmp causes uninitialized stack frame"), but without a test-case that's far outside Geeqie's code. You also forgot to attach the svg file, but if the problem is not reproducible, there's nothing that can be done here. You've reported this before, btw.

*** This bug has been marked as a duplicate of bug 678397 ***

Note You need to log in before you can comment on or make changes to this bug.