Bug 882133 - remote-viewer manual and help don't mention the new added GUI tool
remote-viewer manual and help don't mention the new added GUI tool
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Marc-Andre Lureau
Virtualization Bugs
:
Depends On:
Blocks: 921345
  Show dependency treegraph
 
Reported: 2012-11-30 03:31 EST by yuping zhang
Modified: 2013-11-21 03:04 EST (History)
12 users (show)

See Also:
Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Bug Fix
Doc Text:
no doc required
Story Points: ---
Clone Of:
: 921345 (view as bug list)
Environment:
Last Closed: 2013-11-21 03:04:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (1.04 KB, patch)
2013-05-09 19:27 EDT, Marc-Andre Lureau
no flags Details | Diff

  None (edit)
Description yuping zhang 2012-11-30 03:31:06 EST
Description of problem:
Remote-viewer add a new GUI tool for connection,but no document mention it.
#man remote-viewer
#remote-viewer -h

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-16.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.Run #remote-viewer
2. #man remote-viewer or #remote-viewer -h
3.
 
Actual results:
Remote-viewer manual and help don't mention it.

Expected results:
This new GUI tool should be introduced in manual

Additional info:
Comment 1 Daniel Berrange 2012-11-30 03:35:34 EST
I think your installation is broken, because remote-viewer does have a man page included in the RPM and viewing it works fine for me.

$ rpm -qlp virt-viewer-0.5.2-16.el6.x86_64.rpm | grep man
/usr/share/man/man1/remote-viewer.1.gz
/usr/share/man/man1/virt-viewer.1.gz
Comment 2 yuping zhang 2012-11-30 03:43:17 EST
(In reply to comment #1)
> I think your installation is broken, because remote-viewer does have a man
> page included in the RPM and viewing it works fine for me.
> 
> $ rpm -qlp virt-viewer-0.5.2-16.el6.x86_64.rpm | grep man
> /usr/share/man/man1/remote-viewer.1.gz
> /usr/share/man/man1/virt-viewer.1.gz

Hi Daniel,
The manual page works well,I mean the manual page doesn't mention the new added graphic tool.
I found that there is a new graphic tool after run remote-viewer without a URI,so I think the tool should be described in remote-viewer manual. Dose it make sense?

Thanks,
Yuping
Comment 3 Daniel Berrange 2012-11-30 03:46:07 EST
Ah ok, thanks for clarifying
Comment 7 Marc-Andre Lureau 2013-05-09 19:27:21 EDT
Created attachment 745836 [details]
proposed patch
Comment 8 Marc-Andre Lureau 2013-05-09 19:28:11 EDT
ok with this change?
thanks
Comment 9 Cui Lei 2013-05-09 20:56:35 EDT
Hi, Marc-Andre
I think the change is OK.
Thanks
Comment 10 Cui Lei 2013-05-09 21:00:15 EDT
Comment 9 is provide the needinfo, so remove the tag.
Comment 15 tingting zheng 2013-07-03 06:40:50 EDT
Tested with:
virt-viewer-0.5.6-1.el6.x86_64

# man remote-viewer
DESCRIPTION
       remote-viewer is a simple remote display client. The supported protocols are SPICE and VNC.

       Starting remote-viewer without URI will open a simple dialog with an entry and a list of
       previously successfully access URI.


The manual has mentioned the GUI tool,so move the bug as VERIFIED.
Comment 16 errata-xmlrpc 2013-11-21 03:04:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html

Note You need to log in before you can comment on or make changes to this bug.