Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 882134 - Recent connections cannot remember the spice connect in remote-viewer GUI tool
Summary: Recent connections cannot remember the spice connect in remote-viewer GUI tool
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-30 08:37 UTC by yuping zhang
Modified: 2013-11-21 08:05 UTC (History)
14 users (show)

Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 08:05:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (15.08 KB, image/png)
2012-11-30 08:39 UTC, yuping zhang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1578 0 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-11-20 21:39:50 UTC

Description yuping zhang 2012-11-30 08:37:19 UTC
Description of problem: 
Open remote-viewer GUI tool,connect some guests with spice and vnc protocol.No spice connections are remembered. 

Version-Release number of selected component (if applicable): 
virt-viewer-0.5.2-16.el6.x86_64 

How reproducible: 
always 

Steps to Reproduce: 
1.Prepare some guests,some of them use vnc protocol,the other use spice. 
2.Run #remote-viewer 
3.Connect the guests with input URL:spice://*** or vnc://*** 
4.Run #remote-viewer check the connections in "Recent connections:" 

Actual results: 
Only vnc connections are remembered.No spice connections are remembered. 

Expected results: 
Spice connections should still be remembered. 

Additional info:

Comment 1 yuping zhang 2012-11-30 08:39:08 UTC
Created attachment 654868 [details]
screenshot

Comment 5 Marc-Andre Lureau 2013-05-09 21:47:40 UTC
This is fixed since v0.5.4-27-g30b5366 (session-connected was sent too early, before the handler was attached)

Comment 10 tingting zheng 2013-07-04 02:42:43 UTC
I can reproduce this issue with:
virt-viewer-0.5.2-18.el6_4.2.x86_64

Tested and verified the bug with:
virt-viewer-0.5.6-1.el6.x86_64

Both vnc and spice connections are remembered in "Recent connections:",so move the bug as VERIFIED.

Comment 11 errata-xmlrpc 2013-11-21 08:05:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html


Note You need to log in before you can comment on or make changes to this bug.