This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 882148 - virt-manager with no running VMs consumes huge amounts of memory
virt-manager with no running VMs consumes huge amounts of memory
Status: CLOSED DUPLICATE of bug 972371
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-30 04:30 EST by Honza Horak
Modified: 2013-06-12 15:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 15:37:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Honza Horak 2012-11-30 04:30:14 EST
Description of problem:
I've had virt-manager running for few days (including suspending) and did approx. 10 actions like start/stop VM (VM were RHEL-5, RHEL-6, Fedora). Finally there is no running VM, but virtual-manager still consumes a huge amounts of memory and even consumes quite a lot processor time:

USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
hhorak    8151  3.8 16.0 1567028 617416 ?      Ssl  Nov27 166:06 python /usr/share/virt-manager/virt-manager.py

Version-Release number of selected component (if applicable):
virt-manager-0.9.4-3.fc18.noarch

How reproducible:
usually after several days of running

Steps to Reproduce:
1. work with virt-manager few days (start/stop VMs)
2. do some suspends
3. see virt-manager's consumed memory
  
Actual results:
virt-manager consumes over 500MB when no VM is running any more

Expected results:
virt-manager consumes say 50MB, like when it is fresh started
Comment 1 Cole Robinson 2013-06-12 15:37:46 EDT

*** This bug has been marked as a duplicate of bug 972371 ***

Note You need to log in before you can comment on or make changes to this bug.