Bug 882226 - ARM platforms lack NUMA node information
ARM platforms lack NUMA node information
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
arm7 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks: LibvirtNonX86
  Show dependency treegraph
 
Reported: 2012-11-30 07:55 EST by Daniel Berrange
Modified: 2016-03-23 20:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-23 20:08:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
udevadm info --export-db for devices (114.44 KB, text/plain)
2012-11-30 07:55 EST, Daniel Berrange
no flags Details

  None (edit)
Description Daniel Berrange 2012-11-30 07:55:57 EST
Created attachment 655006 [details]
udevadm info --export-db for devices

Description of problem:
I have an Chromebook with a Cortex A-15  ARM CPU. Libvirt is not reporting any NUMA information in virsh capabilites, 

# virsh capabilities
<capabilities>

  <host>
    <uuid>7383f7f7-b337-d1cb-1062-aa6e25ba591f</uuid>
    <cpu>
      <arch>armv7l</arch>
    </cpu>
    <power_management>
      <suspend_mem/>
    </power_management>
    <migration_features>
      <live/>
      <uri_transports>
        <uri_transport>tcp</uri_transport>
      </uri_transports>
    </migration_features>
  </host>

</capabilities>


though nodeinfo says there is 1 node


# virsh nodeinfo
CPU model:           armv7l
CPU(s):              2
CPU frequency:       0 MHz
CPU socket(s):       1
Core(s) per socket:  2
Thread(s) per core:  1
NUMA cell(s):        1
Memory size:         2069816 kB

# virsh freecell
error: this function is not supported by the connection driver: NUMA memory information not available on this platform


The cause is that numactl is x86-only. For other platforms libvirt simply disables NUMA information. A more satisfactory approach is probably to just report a single node in the capabilities, and make freecell hardcode a single node.

This allows applications to use the NUMA functionality regardless of platform



Version-Release number of selected component (if applicable):
libvirt-client-0.9.11.6-1.fc17.armv7hl

How reproducible:
Always
Comment 1 Cole Robinson 2016-03-23 20:08:57 EDT
commit 8d3d05d3c16d39bf993833d18e04902c5ff454cf
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Wed Apr 3 21:11:15 2013 +0100

    Create fake NUMA info if libnuma isn't available

Note You need to log in before you can comment on or make changes to this bug.