Bug 882236 - lxc: migration to /etc/hostname, /etc/vconsole.conf, /etc/locale.conf
lxc: migration to /etc/hostname, /etc/vconsole.conf, /etc/locale.conf
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lxc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Moschny
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 881785
  Show dependency treegraph
 
Reported: 2012-11-30 08:29 EST by Kay Sievers
Modified: 2014-09-02 02:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: lxc-1.0.5-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-01 23:54:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kay Sievers 2012-11-30 08:29:04 EST
Fedora is migrating away from:
 /etc/sysconfig/network (the HOSTNAME=... setting)
 /etc/sysconfig/keyboard
 /etc/sysconfig/i18n
to:
 /etc/hostname
 /etc/vconsole.conf
 /etc/locale.conf

See the tracker bug 881785 for details.

We found:
 lxc-fedora.in: cat <<EOF > ${rootfs_path}/etc/sysconfig/network

Please update the package for the new config files.

The old files are converted and deleted from the system at update time.
If reading the old files is still supported, please make sure they are
never created again.

Thanks!
Comment 1 Michael H. Warfield 2014-06-04 16:59:44 EDT
The LXC Fedora template only references /etc/sysconfig/network and not the others.  The upstream template now supports both /etc/hostname and HOSTNAME= in /etc/sysconfig/network but a discrepancy has been pointed out to me.  Specification for /etc/hostname is that it's a simple name and can contain no dots.  But the HOSTNAME= was an FQDN.  Where did the FQDN migrate to or is the information on /etc/hostname incorrect (as it appears)?

Not sure why this would be a blocker, other than supporting /etc/hostname, which upstream currently does since 1.0.0.
Comment 2 Fedora Update System 2014-08-08 06:26:18 EDT
lxc-1.0.5-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/lxc-1.0.5-2.el6
Comment 3 Fedora Update System 2014-08-08 06:26:35 EDT
lxc-1.0.5-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/lxc-1.0.5-2.fc19
Comment 4 Fedora Update System 2014-08-08 06:26:51 EDT
lxc-1.0.5-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lxc-1.0.5-2.fc20
Comment 5 Fedora Update System 2014-08-08 20:07:41 EDT
Package lxc-1.0.5-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing lxc-1.0.5-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2167/lxc-1.0.5-2.el6
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-09-01 23:54:29 EDT
lxc-1.0.5-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2014-09-02 02:40:11 EDT
lxc-1.0.5-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2014-09-02 02:46:29 EDT
lxc-1.0.5-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.