Bug 882245 - After rhevm-guest-agent uninstallation there's still 'ovirtagent' user/group in OS and /dev/vport01p1 still uses 'ovirtagent' uid/gid
After rhevm-guest-agent uninstallation there's still 'ovirtagent' user/group ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.2.0
Assigned To: Vinzenz Feenstra [evilissimo]
Jiri Belka
virt
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-11-30 08:43 EST by Jiri Belka
Modified: 2013-06-10 16:10 EDT (History)
7 users (show)

See Also:
Fixed In Version: rhevm-guest-agent-1.0.7-3.el6ev
Doc Type: Bug Fix
Doc Text:
Cause: After removal the udev rules have not been reapplied Consequence: The /dev/vport01p1 device still was assigned to the ovirtagent user. Fix: The udev rules are reset. Result: The /dev/vport01p1 device is now owned by root:root after removal of the guest agent package.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 16:10:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2012-11-30 08:43:41 EST
Description of problem:

After rhevm-guest-agent uninstallation there's still 'ovirtagent' user/group in OS and /dev/vport01p1 still uses 'ovirtagent' uid/gid. Uninstalled should make correct cleaning after itself.

...snip...
Running Transaction
  Erasing    : rhevm-guest-agent-gdm-plugin-1.0.5-5.el6ev.x86_64                                                                                                                           1/3 
  Erasing    : rhevm-guest-agent-pam-module-1.0.5-5.el6ev.x86_64                                                                                                                           2/3 
  Erasing    : rhevm-guest-agent-1.0.5-5.el6ev.x86_64                                                                                                                                      3/3 
warning: /etc/ovirt-guest-agent.conf saved as /etc/ovirt-guest-agent.conf.rpmsave
Installed products updated.
  Verifying  : rhevm-guest-agent-1.0.5-5.el6ev.x86_64                                                                                                                                      1/3 
  Verifying  : rhevm-guest-agent-gdm-plugin-1.0.5-5.el6ev.x86_64                                                                                                                           2/3 
  Verifying  : rhevm-guest-agent-pam-module-1.0.5-5.el6ev.x86_64                                                                                                                           3/3 

Removed:
  rhevm-guest-agent.x86_64 0:1.0.5-5.el6ev                rhevm-guest-agent-gdm-plugin.x86_64 0:1.0.5-5.el6ev                rhevm-guest-agent-pam-module.x86_64 0:1.0.5-5.el6ev               

Complete!

[root@rhel6ws64 ~]# ls -l /dev/vport0p*
crw-rw----. 1 ovirtagent ovirtagent 249, 1 Nov 30 13:57 /dev/vport0p1
crw-rw----. 1 root       root       249, 2 Nov 30 13:57 /dev/vport0p2
crw-rw----. 1 root       root       249, 3 Nov 30 13:57 /dev/vport0p3
[root@rhel6ws64 ~]# grep agent /etc/{passwd,group}
/etc/passwd:ovirtagent:x:175:175:oVirt Guest Agent:/:/sbin/nologin
/etc/group:ovirtagent:x:175:


Version-Release number of selected component (if applicable):

(from devs - https://brewweb.devel.redhat.com/taskinfo?taskID=5145336)
rhevm-guest-agent-gdm-plugin-1.0.5-5.el6ev.x86_64
rhevm-guest-agent-pam-module-1.0.5-5.el6ev.x86_64
rhevm-guest-agent-1.0.5-5.el6ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install
2. Uninstall
3. Check /etc/{passwd,group} and /dev/vport0p1
  
Actual results:

Uninstallation doesn't make full cleaning after itself.

Expected results:

Clean env.
Additional info:
Comment 1 Vinzenz Feenstra [evilissimo] 2012-12-18 10:22:29 EST
Users and groups are not supposed to be removed.

We can reset the user/group during removal.
Comment 2 Vinzenz Feenstra [evilissimo] 2012-12-20 10:52:11 EST
Upstream Change
ChangeSet: http://gerrit.ovirt.org/#/c/10286/1
Comment 4 Jiri Belka 2013-01-22 07:17:22 EST
OK, 1.0.7-3.el6ev on si26/rhel6.4.
Comment 5 Cheryn Tan 2013-04-09 00:15:34 EDT
This bug is currently attached to errata RHEA-2013:14354. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.

* Consequence: What happens when the bug presents.

* Fix: What was done to fix the bug.

* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks in advance.
Comment 6 errata-xmlrpc 2013-06-10 16:10:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0914.html

Note You need to log in before you can comment on or make changes to this bug.