Bug 882248 - [RFE] Environment renaming should be enabled
[RFE] Environment renaming should be enabled
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Jordan OMara
SAM QE List
: FutureFeature
Depends On: 795928
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-30 08:51 EST by Tom McKay
Modified: 2014-11-09 17:56 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 795928
Environment:
Last Closed: 2013-08-06 05:39:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2012-11-30 08:51:04 EST
+++ This bug was initially created as a clone of Bug #795928 +++

See 787226 for reasons renaming was disabled. This disable, though, is only a short-term fix to avoid larger issues and needs to be resolved.

-----
Since we base the repoid in pulp off of the environment name, we really
shouldn't be able to rename it, as it could cause problems. 

One such scenario that could cause issues:


1. create environment Dev
2. promote repo X to dev
3. rename environment Dev to Foo
4. Create a new environment called Dev after Foo
5. promote repo X to Dev


Since the repo was already created in an environment called Dev, the repo
promotion would fail.  


Ideally we wouldn't be basing repo_id off of environment name.  There was some
discussion on having an immutable label field, which should allow us to have a
name that is changeable, but this is probably post V1.


We need to block this in the UI and the api.
Comment 1 Jordan OMara 2012-12-18 11:27:42 EST
https://github.com/Katello/katello/pull/1281
Comment 2 Bryan Kearney 2013-06-06 16:50:58 EDT
Moving all POST / MODIFIED bugs to ON_QA due to the new builds.
Comment 3 Tazim Kolhar 2013-08-06 04:06:46 EDT
Hi,

  Environments is not supported in Headpin/SAM mode

Please, let me know if we still need to verify for default_environment
LIBRARY

Thanks,
Tazim
Comment 4 Tom McKay 2013-08-06 05:39:46 EDT
Environments are no longer supported in headpin mode. The single behind-the-scenes environment is Library, which even in katello cannot be modified.

Note You need to log in before you can comment on or make changes to this bug.