Bug 882268 - vdsClient reports still old data after upgrade to rhevm-guest-agent on RHEL6 32bit
vdsClient reports still old data after upgrade to rhevm-guest-agent on RHEL6 ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent (Show other bugs)
3.1.0
i686 Linux
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Vinzenz Feenstra [evilissimo]
Jiri Belka
virt
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-11-30 09:31 EST by Jiri Belka
Modified: 2013-06-10 16:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: A backward compatibility fix previously reported the 'rhev-agent' package to be installed as well. Consequence: Misinformation reported in the RHEVM WebAdmin portal under the installed applications. Fix: The old package is no longer reported. Result: The misleading information is no longer shown in the RHEVM WebAdmin portal
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 16:12:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2012-11-30 09:31:48 EST
Description of problem:

vdsClient reports still old data after upgrade to rhevm-guest-agent on RHEL6 32bit, it still reports installed 'rhev-agent' which was uninstalled during upgrade. Several restarts of ovirt-guest-agent were done of course.

[root@localhost ~]# service ovirt-guest-agent restart
Stopping ovirt-guest-agent:                                [  OK  ]
Starting ovirt-guest-agent:                                [  OK  ]
[root@localhost ~]# rpm -qa | grep rhev
rhevm-guest-agent-pam-module-1.0.5-5.el6ev.i686
rhevm-guest-agent-gdm-plugin-1.0.5-5.el6ev.i686
rhevm-guest-agent-1.0.5-5.el6ev.i686
[root@localhost ~]# grep ^app /etc/ovirt-guest-agent.conf
applications_list = kernel rhevm-guest-agent xorg-x11-drv-qxl

[root@dell-r210ii-04 vdsm]# vdsClient -s 0 getVmStats 2545aff1-dde2-4ce1-9de6-da6e82e8fa5c | grep appsList
        appsList = ['kernel-2.6.32-279.el6', 'kernel-2.6.32-279.14.1.el6', 'rhev-agent-1.0.5-5.el6ev', 'rhevm-guest-agent-1.0.5-5.el6ev']


Version-Release number of selected component (if applicable):

rhevm-guest-agent-gdm-plugin-1.0.5-5.el6ev.i686
rhevm-guest-agent-1.0.5-5.el6ev.i686
rhevm-guest-agent-pam-module-1.0.5-5.el6ev.i686


How reproducible:

100%

Steps to Reproduce:
1. Install IC agent.
2. Upgrade to SI agents from https://brewweb.devel.redhat.com/taskinfo?taskID=5148633
3. make agent working and check vdsClient and WAP for isntalled apps
  
Actual results:

Reported name of rhev-agent as installed app.

Expected results:

Should report valid installed apps.

Additional info:
Comment 1 Jiri Belka 2012-11-30 09:40:03 EST
WAP = web admin portal, it means "bad" data are even in web admin portal.
Comment 2 Jiri Belka 2012-11-30 09:43:29 EST
Same on x86_64.
Comment 3 Michal Skrivanek 2012-11-30 11:44:32 EST
this is intentional. waiting on gal/barak to comment why and if it's still needed
Comment 4 Gal Hammer 2012-12-02 10:21:24 EST
It was needed in order to support old GUI. I don't know what is the logic in the new GUI.
Comment 9 Jiri Belka 2013-01-31 08:46:02 EST
OK, sf4 & rhevm-guest-agent-common-1.0.7-4.el6ev.noarch.
Comment 10 Cheryn Tan 2013-04-09 00:17:25 EDT
This bug is currently attached to errata RHEA-2013:14354. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.

* Consequence: What happens when the bug presents.

* Fix: What was done to fix the bug.

* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks in advance.
Comment 11 errata-xmlrpc 2013-06-10 16:12:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0914.html

Note You need to log in before you can comment on or make changes to this bug.