Bug 882277 - cluster-cim: missing symbols/provider library not compiled properly
cluster-cim: missing symbols/provider library not compiled properly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: clustermon (Show other bugs)
5.9
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Jan Pokorný
michal novacek
: EasyFix, ZStream
Depends On: 865588
Blocks: 928849 957651 958026
  Show dependency treegraph
 
Reported: 2012-11-30 10:00 EST by michal novacek
Modified: 2013-09-30 18:10 EDT (History)
8 users (show)

See Also:
Fixed In Version: clustermon-0.12.1-8.el5
Doc Type: Bug Fix
Doc Text:
Prior to this update, the dynamic library that represents the CIM provider of a cluster status was not built with all the required dependencies, and certain symbols could not be resolved. As a consequence, the cluster status could not be accessed by CIM. This update adds the missing dependencies to the dynamic library, and the cluster status is now accessible as expected.
Story Points: ---
Clone Of: 865588
: 957651 (view as bug list)
Environment:
Last Closed: 2013-09-30 18:10:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer bash script (changed path to .mof files) (622 bytes, text/plain)
2013-05-30 08:46 EDT, michal novacek
no flags Details

  None (edit)
Comment 3 Jan Pokorný 2013-04-22 16:26:45 EDT
Patch reflects the one for [bz865588] (linkt with necessary local object
and rt).
Comment 11 michal novacek 2013-05-30 08:46:22 EDT
Created attachment 754835 [details]
reproducer bash script (changed path to .mof files)
Comment 12 michal novacek 2013-05-30 08:58:57 EDT
verified with reproducer script in attachment 655103 [details]

# clustat
Cluster Status for STSRHTS29545 @ Thu May 30 08:49:25 2013
Member Status: Quorate

 Member Name                                 ID   Status
 ------ ----                                 ---- ------
 virt-011.cluster-qe.lab.eng.brq.redhat.com      1 Online, Local
 virt-014.cluster-qe.lab.eng.brq.redhat.com      2 Online


BUGGY version: cluster-cim-0.12.1-7.el5

# ./reproducer.sh 
+ trap err ERR
...
+ wbemcli ei http://root:beaker@localhost:5988/root/cimv2:RedHat_Cluster
*
* wbemcli: Cim: (1) CIM_ERR_FAILED: ProviderLoadFailure \
 (/usr/lib64/Pegasus/providers/libRedHatClusterProvider.so:RedHatClusterProvider):Cannot \
 load library, error: \
 /usr/lib64/Pegasus/providers/libRedHatClusterProvider.so: undefined symbol: \
 _ZN17ClusterMonitoring7Cluster15runningServicesEv
*

----

CORRECTED version: cluster-cim-0.12.1-10.el5

# ./reproducer.sh 
+ trap err ERR
...
+ wbemcli ei http://root:beaker@localhost:5988/root/cimv2:RedHat_Cluster

+ wbemcli ei http://root:beaker@localhost:5988/root/cimv2:RedHat_Cluster
localhost:5988/root/cimv2:RedHat_Cluster.*KEYBINDING="MISSING*" Name="STSRHTS29545",Votes=2,VotesNeededForQuorum=2,MaxNumberOfNodes=0,NodesNumber=2,AvailableNodesNumber=2,UnavailableNodesNumber=0,NodesNames="virt-011.cluster-qe.lab.eng.brq.redhat.com","virt-014.cluster-qe.lab.eng.brq.redhat.com",AvailableNodesNames="virt-011.cluster-qe.lab.eng.brq.redhat.com","virt-014.cluster-qe.lab.eng.brq.redhat.com",UnavailableNodesNames=,ServicesNumber=0,RunningServicesNumber=0,StoppedServicesNumber=0,FailedServicesNumber=0,ServicesNames=,RunningServicesNames=,StoppedServicesNames=,FailedServicesNames=,OperationalStatus=2,StatusDescriptions="All services and nodes functional",ClusterState=2,Types=2,CreationClassName="RedHat_Cluster"
Comment 14 errata-xmlrpc 2013-09-30 18:10:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1305.html

Note You need to log in before you can comment on or make changes to this bug.