Bug 882278 - [FEAT] NUFA
[FEAT] NUFA
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jeff Darcy
:
: 772360 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-30 10:03 EST by Jeff Darcy
Modified: 2013-07-24 13:50 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:50:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Darcy 2012-11-30 10:03:05 EST
For those who might not know, NUFA is a variant of DHT which places newly created files locally if possible. It used to be quite popular with people who ran "symmetric" configurations (all nodes are both clients and servers) and had apps that wrote lots of scratch files. It still builds and seems to run, but had become deprecated due to the need for special configuration not supported by our CLI. Recently, a few users on the mailing list have specifically asked to have it back, so I did some investigation and it looks like it shouldn't be hard to revive it in a simplified form. Specifically, it can figure out on its own which subvolume is local, so no complex configuration is necessary - just one option to enable it.
Comment 1 Amar Tumballi 2012-12-03 01:32:56 EST
http://review.gluster.org/4234
Comment 2 Vijay Bellur 2012-12-04 17:42:26 EST
CHANGE: http://review.gluster.org/4234 (dht: support auto-NUFA option) merged in master by Anand Avati (avati@redhat.com)
Comment 3 shishir gowda 2013-03-22 01:56:21 EDT
*** Bug 772360 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.