Bug 882339 - spice-xpi doesn't clean up /tmp/spicec-XXXXXX/spice-foreign socket and /tmp/spicec-XXXXXX directory after the client exits
Summary: spice-xpi doesn't clean up /tmp/spicec-XXXXXX/spice-foreign socket and /tmp/s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-xpi
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: beta
: ---
Assignee: Peter Hatina
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 947781
TreeView+ depends on / blocked
 
Reported: 2012-11-30 17:36 UTC by David Jaša
Modified: 2016-06-01 01:31 UTC (History)
8 users (show)

Fixed In Version: spice-xpi-2.7-23.el6
Doc Type: Bug Fix
Doc Text:
Cause: The spice-xpi browser plugin was not cleaning up some socket files after client exit Consequence: /tmp/spicec-XXXXXX/spice-foreign socket and /tmp/spicec-XXXXXX directory are still present after the client exits. Fix: Remove these files when the clients exits Result: These 2 files no longer stay around
Clone Of:
Environment:
Last Closed: 2013-11-21 21:40:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1667 normal SHIPPED_LIVE spice-xpi bug fix and enhancement update 2013-11-20 21:52:56 UTC

Description David Jaša 2012-11-30 17:36:57 UTC
Description of problem:
spice-xpi doesn't clean up /tmp/spicec-XXXXXX/spice-foreign socket and /tmp/spicec-XXXXXX directory after the client exits.

spice-xpi creates /tmp/spicec-XXXXXX directory with two sockets before it launches the client: spice-xpi and spice-foreign, but it doesn't clean them up after client exit.

The file and directory can be left unremoved even when this bug is fixed in cases when plugin exits before the client but these cases should be much rarer than current leaving of every file.

Version-Release number of selected component (if applicable):
spice-xpi-2.7-22.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. close all clients launched by browser plugin
2. remove all /tmp/spicec-XXXXXX directories
3. launch a client from portal, close the client again
  
Actual results:
/tmp/spicec-XXXXXX/spice-foreign directory and socket are left behind

Expected results:
no /tmp/spicec-XXXXXX directory exists anymore

Additional info:

Comment 1 Christophe Fergeau 2013-05-21 09:21:09 UTC
A patch for this issue was sent to the spice-devel mailing list:
http://lists.freedesktop.org/archives/spice-devel/2013-April/012995.html

Comment 3 Peter Hatina 2013-06-17 13:31:14 UTC
Please, check this scratch build.

https://brewweb.devel.redhat.com/taskinfo?taskID=5910797

Comment 4 Tomas Jamrisko 2013-06-18 10:29:15 UTC
Seems to work with the build from Comment 3.

Comment 5 Peter Hatina 2013-06-18 10:41:21 UTC
OK, fixed.

Comment 6 Christophe Fergeau 2013-06-19 11:56:45 UTC
Does this issue happen upstream as well? If it does, this needs to get fixed there as well if we don't want to introduce a regression if we rebase or in rhel7

Comment 13 errata-xmlrpc 2013-11-21 21:40:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1667.html


Note You need to log in before you can comment on or make changes to this bug.