Bug 882353 - HTML element being rendered unescaped in promotions help tip.
HTML element being rendered unescaped in promotions help tip.
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Og Maciel
sthirugn@redhat.com
:
Depends On: 882294
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-11-30 13:17 EST by Tom McKay
Modified: 2013-01-08 14:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 882294
Environment:
Last Closed: 2013-01-08 14:01:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2012-11-30 13:17:57 EST
+++ This bug was initially created as a clone of Bug #882294 +++

Created attachment 655119 [details]
screenshot

Description of problem:

The (attached) screenshot shows how the html element <br/> is not being rendered correctly in the promotions help tip. We should not be seeing the characters <br/> but a new line instead.

Version-Release number of selected component (if applicable):

* candlepin-0.7.19-1.el6.noarch
* candlepin-selinux-0.7.19-1.el6.noarch
* candlepin-tomcat6-0.7.19-1.el6.noarch
* foreman-1.0.1-37.ff16a26.el6.noarch
* foreman-postgresql-1.0.1-37.ff16a26.el6.noarch
* katello-1.2.1-1.git.550.af55a68.el6.noarch
* katello-all-1.2.1-1.git.550.af55a68.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.9-1.el6.noarch
* katello-cli-1.2.1-1.git.414.2e4c0be.el6.noarch
* katello-cli-common-1.2.1-1.git.414.2e4c0be.el6.noarch
* katello-common-1.2.1-1.git.550.af55a68.el6.noarch
* katello-configure-1.2.0-1.git.573.dd0cd53.el6.noarch
* katello-glue-candlepin-1.2.1-1.git.550.af55a68.el6.noarch
* katello-glue-foreman-1.2.1-1.git.550.af55a68.el6.noarch
* katello-glue-pulp-1.2.1-1.git.550.af55a68.el6.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-repos-1.2.1-1.git.34.5c113ae.el6.noarch
* katello-selinux-1.1.2-1.el6.noarch
* pulp-1.1.12-1.el6.noarch
* pulp-common-1.1.12-1.el6.noarch
* pulp-selinux-server-1.1.12-1.el6.noarch

How reproducible:


Steps to Reproduce:
1. Navigate to the Changesets page
2. Look at the help tip
3.
  
Actual results:


Expected results:


Additional info:

--- Additional comment from RHEL Product and Program Management on 2012-11-30 10:56:29 EST ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Og Maciel on 2012-11-30 12:19:56 EST ---

Fixed by commit 5ff7384fe1971ff830a29101e673daa44ca67dc0.
Comment 2 sthirugn@redhat.com 2013-01-08 14:01:39 EST
This bug is not applicable to SAM.  Closing this as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.