Bug 882397 - rd.live.check fails on Lenovo Ideapad Y470
rd.live.check fails on Lenovo Ideapad Y470
Status: CLOSED DUPLICATE of bug 874486
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-30 16:09 EST by Gary Gatling
Modified: 2012-12-03 14:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-03 14:51:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Gatling 2012-11-30 16:09:19 EST
Description of problem: The line:

rd.live.check in the f18 beta boot/install media causes the boot process to hang forever on my Lenovo Ideapad Y470 notebook computer. I am not sure why the media check is failing... Removing the "quiet" line in the boot arguments does not seem to provide more information about why the media check is failing...

Version-Release number of selected component (if applicable):

Fedora-18-Beta-x86_64-DVD.iso

How reproducible:

Obtain Lenovo Ideapad y470 notebook computer. Attempt to install f18 beta on it.
(Not sure if other makes / models are affected...)

Steps to Reproduce:
1. Boot disk normally to start install. It hangs at :
dracut-initqueue[369]: mount /dev/sr0 is write protected, mounting read only.
2. 
3.
  
Actual results:

Install hangs at 

dracut-initqueue[369]: mount /dev/sr0 is write protected, mounting read only.

Expected results:

Should start X and anaconda and then ask me about what language I would like to use.

Additional info:

If I press "tab" at boot time and delete the section "rd.live.check" and press "Enter" then the installer gets to the point where it asks me what language I would like to use so I am able to proceed with install of fedora 18 beta.
Comment 1 Brian Lane 2012-12-03 12:14:09 EST
Does hitting ESC while it is hung do anything? It should cancel the mediacheck and continue to boot.

Is there an activity light for your optical drive? Is it doing anything?

Currently the output from the mediacheck gets eaten by something, so it may look like it is stuck when it is actually running.
Comment 2 Gary Gatling 2012-12-03 13:10:38 EST
Hello.

If I press "ESC" key multiple times, either on external USB keyboard or my laptop's built in keyboard, it just adds:

^]^]^]

under the "dracut-initqueue[369]: mount /dev/sr0 is write-protected, mounting read-only" line in the little white box (xterm I'm guessing) in the left corner of the screen. I am unable to complete the install by pressing "ESC". Also, the optical drive light is on and lit once the install starts and it is still on when the mediacheck program is hung.

The only way out at this point is either "CTRL-ALT-DEL" keyboard sequence or a power cycle.

Hope that helps.

Cheers,
Comment 3 Gary Gatling 2012-12-03 13:42:01 EST
Due to an email I just saw on the testing mailing list, In case it was a situation where I wasn't waiting long enough, I just tried again and I left it sitting from 1:18 EST today until like 1:30pm and after 11 minutes it did finally finish. (ESC has no effect on this delay) I am not sure if a "typical" user will know to wait that long however? ;)
I didn't haha, doh.

Cheers,
Comment 4 Brian Lane 2012-12-03 14:51:12 EST
Thanks for the feedback.

*** This bug has been marked as a duplicate of bug 874486 ***

Note You need to log in before you can comment on or make changes to this bug.