Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 882411 - Manifest import fails when 2 repos in the manifest contain the same string in their path
Summary: Manifest import fails when 2 repos in the manifest contain the same string in...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Management
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Mike McCune
QA Contact: Og Maciel
URL:
Whiteboard:
: 886987 (view as bug list)
Depends On: 882406
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-30 21:46 UTC by Mike McCune
Modified: 2014-09-18 15:31 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
Importing a manifest fails when creating two repositories with a relative path that contains the same sub-string. This blocks System Engine from importing a subscription manifest and syncing Red Hat content. This fix adds a slash (if missing) to the end of the relative path to help distinguish the strings. System Engine 1.1.1 now imports these manifests successfully.
Clone Of: 882406
Environment:
Last Closed: 2013-01-07 14:17:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1603 0 normal SHIPPED_LIVE CloudForms System Engine 1.1.1 bug fix update 2012-12-21 02:37:29 UTC

Comment 5 Mike McCune 2012-12-04 21:55:52 UTC
tested with patch: https://bugzilla.redhat.com/show_bug.cgi?id=882406#c8

and was able to import the manifest with RHEL + OpenShift without error.  moving to POST

Comment 7 Mike McCune 2012-12-14 20:10:54 UTC
*** Bug 886987 has been marked as a duplicate of this bug. ***

Comment 9 james labocki 2012-12-17 23:43:00 UTC
Performed steps in comment 8 on CloudForms System Engine Version: 1.1.12-22.el6cf 

I wasn't able to upload a manifest into the same organization. I have deleted and am waiting to confirm importing into a different organization works.

Comment 10 Og Maciel 2012-12-18 19:33:34 UTC
Verified:

* candlepin-0.7.8.1-1.el6cf.noarch
* candlepin-selinux-0.7.8.1-1.el6cf.noarch
* candlepin-tomcat6-0.7.8.1-1.el6cf.noarch
* elasticsearch-0.18.4-11.el6.noarch
* katello-1.1.12-22.el6cf.noarch
* katello-all-1.1.12-22.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-12.el6cf.noarch
* katello-cli-common-1.1.8-12.el6cf.noarch
* katello-common-1.1.12-22.el6cf.noarch
* katello-configure-1.1.9-12.el6cf.noarch
* katello-glue-candlepin-1.1.12-22.el6cf.noarch
* katello-glue-pulp-1.1.12-22.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-2.el6cf.noarch
* pulp-1.1.15-1.el6cf.noarch
* pulp-common-1.1.15-1.el6cf.noarch
* pulp-selinux-server-1.1.15-1.el6cf.noarch


Note You need to log in before you can comment on or make changes to this bug.