Bug 882447 - Partitioning is very confusing, impossible with LVM
Partitioning is very confusing, impossible with LVM
Status: CLOSED DUPLICATE of bug 860677
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-30 20:46 EST by joshua
Modified: 2012-12-03 13:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-03 13:15:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joshua 2012-11-30 20:46:19 EST
Description of problem:

I'm an LVM person... I love it.  In fact, I love it this much:

$ sudo gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.4

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 117231408 sectors, 55.9 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): F5E0B5A8-ED64-4D64-916A-0EAC9D965641
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 117231374
Partitions will be aligned on 2048-sector boundaries
Total free space is 2014 sectors (1007.0 KiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          411647   200.0 MiB   EF00  EFI System
   2          411648          413695   1024.0 KiB  EF02  BIOS boot partition
   3          413696       117231374   55.7 GiB    8E00  Linux LVM


This works really well for Fedora 17.   However, I'm having troubles adding a Logical Volume with the new F18 installer.  It literally won't let me.  First off, when I say "Don't need help, let me partition by myself", why do I still need to click a "reclaim" button?  At that point, I'm not reclaiming anything, I'm working with the *existing* partitioning / LVM layout.

Once I get to that screen though, I can't add a Logical Volume whatsoever.  Yes, I could add a partition by clicking on the "+" button, but it says "No Space" when I do so.

So how exactly do I get Fedora 18 installed?  I've got LVM space, but the installer refuses to acknowledge it.


Version-Release number of selected component (if applicable):

F18 x86_64 Beta, installer booted in non-UEFI mode
Comment 1 Chris Lumens 2012-12-01 15:48:04 EST
What do you have installed in that LVM space to begin with, and do you want to keep it or not?
Comment 2 joshua 2012-12-01 19:31:18 EST
I have a few different root filesystems, from Fedora 17, 16, etc.
Also have a swap LV, and a /home LV.  I want to keep it all.

That said, I have plenty of space left for another LV to be created to be the root fs of the F18 install.

Where is the dialogue to create such a volume that works with LVM?   I've been using Fedora all the way back to the time when it was called "Red Hat Linux 3.0.3" :-) ... but I can't figure out how to install Fedora 18 Beta with it's new anaconda logic.
Comment 3 David Lehman 2012-12-03 13:14:04 EST
Patches to do this didn't make the beta, but they are on master.
Comment 4 David Lehman 2012-12-03 13:15:01 EST

*** This bug has been marked as a duplicate of bug 860677 ***

Note You need to log in before you can comment on or make changes to this bug.