Bug 88251 - IndexError: list index out of range (Python related)
IndexError: list index out of range (Python related)
Status: CLOSED DUPLICATE of bug 85877
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-samba (Show other bugs)
9
i686 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-08 03:03 EDT by Stephane Jourdan
Modified: 2006-02-21 13:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephane Jourdan 2003-04-08 03:03:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
[root@posjo01 root]# redhat-config-samba
Traceback (most recent call last):
  File "/usr/share/redhat-config-samba/redhat-config-samba.py", line 20, in ?
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/redhat-config-samba/mainWindow.py", line 114, in __init__
    self.propertiesMenu = self.actionMenu.get_children()[1]
IndexError: list index out of range

Version-Release number of selected component (if applicable):
redhat-config-samba-1.0.4-1

How reproducible:
Always

Steps to Reproduce:
1. type "redhat-config-samba" in a terminal
2.
3.
    

Actual Results:  The error shown above

Expected Results:  The redhat-config-samba tool should have popup'd ?

Additional info:

I made 4 installations of the RedHat 9, all with the french environment (language).
3 upgrades from RH8, 1 clean install, and each time, the same error (on
different machines)
Comment 1 Thierry Coppey 2003-04-25 06:28:39 EDT
I've got the same problem, running with RedHat 9.0 using french version at
installation. maybe there is a problem with the localisation (for example an
array isn't initialized), check when "self.actionMenu" gets his children and if
they are set in the french config localisation.

Else why can't we use swat ?? the config file doesn't appears in /etc/xinetd.d/
even when it's manually installed (form the cd > swat-x > install) ? the install
runs normally but the service file doesn't appears.
Comment 2 Jean-Pascal Houde 2003-04-25 16:22:35 EDT
I'm also experiencing the same problem when starting redhat-config-samba, with a
French installation. As it seems to be a language-related bug, I'll try using US
locale next week...
Comment 3 Jean-Pascal Houde 2003-05-03 19:47:24 EDT
It works very well if I do a "export LC_ALL=en_US" before running
"redhat-config-samba"...
Comment 4 Stephane Jourdan 2003-05-05 10:29:19 EDT
In response to #3 : yes, you don't even need to change the whole system language
for it to run properly, a simple 
# lang=en_US redhat-config-samba

works for this one without changing durably anything. 

Comment 5 Brent Fox 2003-05-19 17:33:16 EDT
This bug is a duplicate of bug #85877 and has already been fixed.  Thanks for
your report.

*** This bug has been marked as a duplicate of 85877 ***
Comment 6 Red Hat Bugzilla 2006-02-21 13:52:33 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.