Bug 882513 - No way to install GRUB2 on a different disks partition.
No way to install GRUB2 on a different disks partition.
Status: CLOSED DUPLICATE of bug 872826
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-12-01 11:02 EST by Tapani Björg
Modified: 2012-12-01 15:42 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-12-01 15:42:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tapani Björg 2012-12-01 11:02:04 EST
Description of problem:
Anaconda can't writ the GRUB2 boot-record to a different partition. Only to the MBR of a disk.

Version-Release number of selected component (if applicable):
Anaconda 18.29.2 Fedora18 Beta

How reproducible:
Install on a system with many bootloaders on different partitions and disks. Use a system with BIOS. An UEFI-System acts different.

Steps to Reproduce:
1. Select custom disk layout.
2. If you are lucky, you will find the options for the bootloader behind the text "1 storage device selected" ;-)
3. There you an only select disks. 
Actual results:
The freshly installed Fedora 18 installed is not bootabel or existing MBR will be overwritten. 

Expected results:
Options to chose every exiting portion on the system.

Additional info:
I see the custom disk layout as some expert-tool in the installation process. But to hide options and information in the expert-tool is useless. But even for an experienced Fedora admin not guessable texts like "1 storage device selected" are really worse! Even Gnome does not hide Options in such a puzzling kind. The bootloader options should really be called "bootloader-settings" and not "1 storage device selected" or "selected disks".
Comment 1 Chris Lumens 2012-12-01 15:42:41 EST

*** This bug has been marked as a duplicate of bug 872826 ***

Note You need to log in before you can comment on or make changes to this bug.