Bug 882526 - 2 Swiss German keyboard layouts
Summary: 2 Swiss German keyboard layouts
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-01 17:08 UTC by Tapani Björg
Modified: 2012-12-06 07:29 UTC (History)
4 users (show)

Fixed In Version: anaconda-18.35-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-06 07:29:22 UTC
Type: Bug


Attachments (Terms of Use)

Description Tapani Björg 2012-12-01 17:08:48 UTC
Description of problem:
The are tow different Swiss German keyboard layouts in Anaconda. I've no clue what's the difference?

Version-Release number of selected component (if applicable):
Anaconda 18.29.2, Fedora18 Beta

How reproducible:
every time

Steps to Reproduce:
Set the keyboard layout to Swiss Germen keyboard layout. There are tow "Swiss Germen" layouts, without any funder description.
  
Actual results:
Confusion of the user. There is in use no discoverable difference between the tow layouts.

Expected results:
Only one Swiss German layout or more informations

Additional info:

Comment 1 Vratislav Podzimek 2012-12-03 08:52:45 UTC
This is caused by the way Anaconda uses to get the list of all available layouts. We iterate over languages and add layouts related to each language. Thus 'ch' is added twice -- with 'German' and 'Swiss German' languages. On the other hand we use a dictionary to diplay description for the 'ch' layout and this dictionary contains 'German (German (Switzerland))'. The result is that this item is listed twice.
Because it would be a quite complicated and significant change to list 'ch' once as 'German (German (Switzerland))' and once as 'Swiss German; Alemannic; Alsatian (German (Switzerland))' I'm sending a patch that removes the duplicity resulting in 'ch' listed only once as 'Swiss German; Alemannic; Alsatian (German (Switzerland))' because the 'Swiss German; Alemannic; Alsatian' language is processed before 'German'.

With changes that would be made for bug #859465 this will probably be resolved in a better way.

Comment 2 Tapani Björg 2012-12-03 20:51:48 UTC
The same layout should be listed once. How this is realized, is secondary.

Comment 3 Fedora Update System 2012-12-05 00:57:08 UTC
pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-19380/pykickstart-1.99.22-1.fc18,anaconda-18.35-1.fc18

Comment 4 Fedora Update System 2012-12-05 23:13:28 UTC
Package pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.22-1.fc18 anaconda-18.35-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19380/pykickstart-1.99.22-1.fc18,anaconda-18.35-1.fc18
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2012-12-06 07:29:24 UTC
pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.