Bug 882529 - Comma in state of a point in Swiss German keyboard layout.
Summary: Comma in state of a point in Swiss German keyboard layout.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kbd
Version: 18
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Vitezslav Crhonek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-01 17:27 UTC by Tapani Björg
Modified: 2013-03-12 08:34 UTC (History)
4 users (show)

Fixed In Version: kbd-1.15.3-7.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-12 08:34:12 UTC
Type: Bug


Attachments (Terms of Use)
Output of xkbcomp -xkb $DISPLAY layout.xkb (56.93 KB, text/plain)
2013-01-11 16:28 UTC, Tapani Björg
no flags Details

Description Tapani Björg 2012-12-01 17:27:10 UTC
Description of problem:
In the keyboards numberblock is a decimal-separator integrated. (usually del-key) In Germany is usually comma used  for a decimal-separator. It Switzerland is a point used. The Swiss German keyboard-layout of Linux does set this key to a comma.

Version-Release number of selected component (if applicable):
Fedora 14, 16, 18 beta, Scientific Linux 6.x (may RHEL6 too), Debian, Ubuntu...

How reproducible:
It looks like an non distribution specific problem. (May Red Had knows where to correct it?) OSX and Win don't do this mistake.

Steps to Reproduce:
1. Enable in Fedora, Scientific Linux, Debian or Ubuntu the Swiss German keyboard-layout.
2. press the decimal-separator of the numberblock
  
Actual results:
Comma in state of a point.

Expected results:
A Point out of the box.  ;-)

Additional info:
May the Swiss France keyboard layout needs to be corrected as well.

Comment 1 Peter Hutterer 2012-12-20 23:02:17 UTC
What's the output of setxkbmap -print? If I run setxkbmap -layout ch, the key is assigned KP_Decimal, which _should_ translate into a point.

Comment 2 Tapani Björg 2012-12-21 09:09:16 UTC
[tapbj@localhost ~]$  setxkbmap -layout ch
[tapbj@localhost ~]$  setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+ch+inet(evdev)+terminate(ctrl_alt_bksp)"    };
        xkb_geometry  { include "pc(pc101)"     };
};

Comment 3 Peter Hutterer 2013-01-01 22:45:24 UTC
what's the output if you enable swiss through your normal means? I doubt you're calling setxkbmap to set the layout on an everyday-basis, right?

just log in normally with the swiss layout, then run setxkbmap -print and xkbcomp -xkb $DISPLAY layout.xkb and attach the file here please.

Comment 4 Tapani Björg 2013-01-02 10:18:33 UTC
No, I don't use setxkbmap at all normaly.
 
Plesa, install any Fedora or CentOS and select the Swiss-German layout while installing and you can reproduse the bug.


[tapbj@localhost ~]$  setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+ch+inet(evdev)+terminate(ctrl_alt_bksp)"    };
        xkb_geometry  { include "pc(pc101)"     };
};
[tapbj@localhost ~]$  xkbcomp -xkb $DISPLAY layout.xkb
[tapbj@localhost ~]$

Comment 5 Tapani Björg 2013-01-11 16:28:07 UTC
Created attachment 676975 [details]
Output of xkbcomp -xkb $DISPLAY layout.xkb

Output of xkbcomp -xkb $DISPLAY layout.xkb

Comment 6 Peter Hutterer 2013-01-26 01:44:54 UTC
weird. to get the KPDL key to be a comma, you need KP_Separator, added by the kpdl:comma section. That one is present in the de layout, not in the ch layout.

The last commit I can see in the ch layout that modifies this dates back to 2007 (fix for https://bugs.freedesktop.org/show_bug.cgi?id=6960)


The layout you attached also uses decimal, not separator:
    key <KPDL> {         [       KP_Delete,      KP_Decimal ] };


what does xev say when you hit the key?

Comment 7 Tapani Björg 2013-01-26 17:27:48 UTC
> 
> what does xev say when you hit the key?

I testet it with Fedora 18 today. xev tells:

KeyRelease event, serial 35, synthetic NO, window 0x2200001,
    root 0xe6, subw 0x0, time 32619216, (833,393), root:(837,418),
    state 0x10, keycode 91 (keysym 0xffae, KP_Decimal), same_screen YES,
    XKeysymToKeycode returns keycode: 129
    XLookupString gives 1 bytes: (2e) "."
    XFilterEvent returns: False

But this is only true in KED. I'm supriced. I discovered, it works as it should in KDE! The decimal-separator of the numberblock is still a comma The Since years I'm used to use the point of the main keyboard block, because I didn't recognize it earlier. Sorry.

BUT, if I open an non X command line, the decimal-separator of the numberblock is still a comma. 

And by the way the often in German used umlauts ä ö ü and the French à è é on the Swiss-German layout does not work in non-X-environment too. I can't write a capital umlaut too... I works all in KDE!

What's the difference between the KDE-layout and the none-KDE keyboard-layout? I'm confused. 

I can't and gonna not test Gnome, LXDE or Xfce.

Comment 8 Peter Hutterer 2013-01-29 06:01:38 UTC
(In reply to comment #7)
> BUT, if I open an non X command line, the decimal-separator of the
> numberblock is still a comma. 

non-X command line? you mean on the ttys? They are using a completely different keyboard configuration tool (unfortunately), specifically they do not use xkeyboard-config.


so for this bug, are we talking about the layout in X or on the tty?

Comment 9 Tapani Björg 2013-01-29 15:48:56 UTC
(In reply to comment #8)
> 
> so for this bug, are we talking about the layout in X or on the tty?

It looks like we talking only about tty.

Comment 10 Vitezslav Crhonek 2013-02-19 15:19:06 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > 
> > so for this bug, are we talking about the layout in X or on the tty?
> 
> It looks like we talking only about tty.

Which keymap do you use for Swiss-German layout in text console?
Should be placed in /etc/vconsole.conf

Comment 11 Tapani Björg 2013-02-19 17:28:39 UTC
[root@mobile0 ~]#  cat /etc/vconsole.conf
FONT=True
KEYMAP=sg
[root@mobile0 ~]#

Comment 12 Vitezslav Crhonek 2013-02-21 15:41:47 UTC
Thanks.

'/lib/kbd/keymaps/i386/qwertz/sg.map.gz' keymap is fixed in kbd-1.15.3-7.fc18.

I'll sent the patch to upstream too.

Comment 13 Fedora Update System 2013-02-21 15:44:40 UTC
kbd-1.15.3-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kbd-1.15.3-7.fc18

Comment 14 Fedora Update System 2013-02-24 08:42:09 UTC
Package kbd-1.15.3-7.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kbd-1.15.3-7.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2930/kbd-1.15.3-7.fc18
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2013-03-12 08:34:14 UTC
kbd-1.15.3-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.