Bug 88254 - ISO-8859-15 fonts badly handled, empty translations
ISO-8859-15 fonts badly handled, empty translations
Product: Red Hat Linux
Classification: Retired
Component: redhat-logviewer (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
Depends On:
  Show dependency treegraph
Reported: 2003-04-08 03:57 EDT by Stephane Jourdan
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-04-21 15:07:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stephane Jourdan 2003-04-08 03:57:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
All accentuation from ISO-8859-15 are dropped and stop the display of the reste
of the word. Example : "Connexion de syst�me" becomes "Connexion de syst". 
The same for every word containing an ISO-8859-15 character.

The second problem is the missing translation for the "Preference" tab, and for
the "reload" tab (not bad translation, there is no translation at all).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Launch redhat-logviewer either by the menu or the console in a french 
language-enabled RH9
2. Watch by yourself

Additional info:

the following error message keeps going at the startup of redhat-logviewer : 

** (redhat-logviewer.py:3397): WARNING **: Invalid UTF8 string passed to
Comment 1 Tammy Fox 2003-04-14 14:10:36 EDT
I am not seeing this problem when I run LANG=fr_FR.UTF-8 redhat-logviewer. Maybe
your translation file (/usr/share/locale/fr/LC_MESSAGES/redhat-logviewer.mo) is
corrupted. Run the command rpm -Va redhat-logviewer to see if the file has been
modified since installation.
Comment 2 Stephane Jourdan 2003-04-15 03:16:02 EDT
Well, rpm -Va redhat-logviewer does not output anything, so I bet nothing has
been modified. 

The translation file is correct with accentuation etc. 

The problem is the display (running LANG=en_US.UTF-8 redhat-logviewer is ok)

Again, it's not a matter of "one install", I did 5 different installations, from
upgrades to clean installs, on different PCs, and each time, same error.
Comment 3 Tammy Fox 2003-04-21 11:37:37 EDT
What happens if you run a different configuration tool such as
redhat-config-users? Do you see the complete translations in it? 

Do you see this problem any where else on your system?

Is it only for the French translations?

Since I see the correct French translations on my machines, I'm thinking it
might not be the redhat-logviewer translations specifically.
Comment 4 Tammy Fox 2003-04-21 15:07:37 EDT
Never mind answering those other questions. I am running the rawhide version,
and that version looks like it displays the French translations fine. The
translation file in version 0.8.5-1 was not in UTF-8 format. Try version 0.8.5-5
from rawhide. It should work fine for you.
Comment 5 Stephane Jourdan 2003-04-22 10:02:00 EDT
Thank you, it's perfect with the version from RawHide !

Note You need to log in before you can comment on or make changes to this bug.