Bug 882542 - manual partitioning too baffling to use
manual partitioning too baffling to use
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-01 14:16 EST by Tom Horsley
Modified: 2013-02-14 11:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 10:15:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
photo of screen I gave up on (142.18 KB, image/jpeg)
2012-12-01 14:16 EST, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2012-12-01 14:16:49 EST
Created attachment 655696 [details]
photo of screen I gave up on

Description of problem:

I have just tried to install fedora 18 beta. My idea was to replace my old
fedora 16 partition with a fedora 18 partition. Since this is on my primary
system, I want to be really sure I know what in the sam hill it is going to
do to my computer. Having finally reached the manual partitioning screen,
I can honestly say I do not have the most microscopic particle of a hint
of a clue what is going on. I have been installing lots of different linux
distros for years for testing things, and I have never been this confused
by a partitioning screen in an installer. It is utterly unusable. There is no
way I'm going to poke and prod things at random to see what works when I'm
talking about my main system here.


Version-Release number of selected component (if applicable):
Whatever is on the Fedora 18 x86_64 DVD iso image

How reproducible:
Every time

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
Brain numbing confusion.

Expected results:
Some microscopic hint of how I might delete an existing partition and reuse the
space for the new fedora 18 install.

Additional info:
I'll attach a photo of the screen in question to identify it.

I'd point out there is about 40 square inches of unused white space on the full
sized screen which could contain explanatory text instead of a handful of cryptic icons.
Comment 1 Adam Williamson 2012-12-03 02:24:29 EST
This is not a bug report, it is a complaint. I'm not snarking, the point is that Bugzilla is completely the wrong tool for this. It is not possible to treat 'I don't know what to do on this screen' as a single bug, because there is no single fix. When should this bug be closed? When we explain the screen to you? When we fix it so you understand it (but what if someone else doesn't?) What if someone else joins in and says they're confused too? Do we address their complaints in this bug too? And so on.

If you have a single concrete request, that can usefully be a bug. Your final sentence is sort of this, but not really.

If you open the '16' and '17' groups, you will see your existing partitions. Custom partitioning in newUI works much like any other partitioning tool, except it groups existing partitions according to the existing OS install they are a part of, it does not group them by their physical location on disk.

The partitions that will form part of your F18 install show up in the 'New F18 Beta install' group, existing partitions show up in all the other groups. You can select a partition on the left hand side and manipulate it on the right, including setting its mount point, device/filesystem type, encryption status, size, whether it should be formatted, etc. You can hit 'apply changes' at any time to see what the proposed layout will be. No changes are actually made until you leave the screen and hit 'Begin Installation' at the hub, so you can poke whatever you like in the screen.
Comment 2 Tom Horsley 2012-12-03 09:42:15 EST
And how did you deduce all that information about how to use the manual partitioning screen? Certainly not by looking at anything on the screen.

> Custom partitioning in newUI works much like any other partitioning tool, except it groups existing partitions according to the existing OS install they are a part of, it does not group them by their physical location on disk.

How about this for a concrete suggestion: A screen designed to do manual partitioning should actually come up with a list of partitions.

What in the blue blazes does existing OS have to do with existing partitions?
An existing OS is installed somewhere on the disk, but so are things like
movie files and spreadsheets. What not pick one of them and list them?
What existing OS are all the shared partitions "associated with"? 
Will the UI crash completely if I try to do manual partitioning starting
with an empty disk that has no existing OS to be "associated with"?

Nothing about this screen makes the slightest particle of sense.
Comment 3 Chris Lumens 2012-12-06 10:15:52 EST
We're not going to sort through a generic "everything is broken!" bug report.  These have a way of growing and growing to consume all issues, making it impossible to tell what's fixed and what's not.  We will be reevaluating parts of the custom part UI after F18 is out, but now is not the time for that.

Note You need to log in before you can comment on or make changes to this bug.