Bug 882573 - [abrt] mate-file-manager-1.5.1-1.fc18: strcmp: Process /usr/bin/caja was killed by signal 11 (SIGSEGV)
Summary: [abrt] mate-file-manager-1.5.1-1.fc18: strcmp: Process /usr/bin/caja was kill...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-file-manager
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Mashal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:cc6e91b4e9afecbf69d4f508660...
: 883275 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-02 00:43 UTC by unix63
Modified: 2013-02-20 21:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-26 06:42:59 UTC


Attachments (Terms of Use)
File: backtrace (99.95 KB, text/plain)
2012-12-02 00:44 UTC, unix63
no flags Details
File: cgroup (129 bytes, text/plain)
2012-12-02 00:44 UTC, unix63
no flags Details
File: core_backtrace (6.72 KB, text/plain)
2012-12-02 00:44 UTC, unix63
no flags Details
File: dso_list (8.72 KB, text/plain)
2012-12-02 00:44 UTC, unix63
no flags Details
File: environ (1.58 KB, text/plain)
2012-12-02 00:44 UTC, unix63
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-02 00:44 UTC, unix63
no flags Details
File: maps (48.66 KB, text/plain)
2012-12-02 00:44 UTC, unix63
no flags Details
File: open_fds (1.16 KB, text/plain)
2012-12-02 00:44 UTC, unix63
no flags Details
File: proc_pid_status (919 bytes, text/plain)
2012-12-02 00:44 UTC, unix63
no flags Details
File: var_log_messages (1.64 KB, text/plain)
2012-12-02 00:44 UTC, unix63
no flags Details
backtrace in gdb following the crash. (4.75 KB, application/octet-stream)
2012-12-13 01:36 UTC, fred smith
no flags Details
corefile dropped by caja when it crashes (47.37 MB, application/octet-stream)
2012-12-14 13:51 UTC, fred smith
no flags Details

Description unix63 2012-12-02 00:43:59 UTC
Description of problem:
In nautilus prefs behave change from single to double click

Version-Release number of selected component:
mate-file-manager-1.5.1-1.fc18

Additional info:
backtrace_rating: 4
cmdline:        caja
crash_function: strcmp
executable:     /usr/bin/caja
kernel:         3.6.7-5.fc18.x86_64
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 strcmp at ../sysdeps/x86_64/strcmp.S:2112
 #1 radio_binding_setting_changed at caja-file-management-properties.c:879
 #6 g_settings_real_change_event at gsettings.c:288
 #7 ffi_call_unix64 at ../src/x86/unix64.S:75
 #8 ffi_call at ../src/x86/ffi64.c:486
 #9 g_cclosure_marshal_generic_va at gclosure.c:1550
 #10 _g_closure_invoke_va at gclosure.c:840
 #13 settings_backend_changed at gsettings.c:348
 #14 g_settings_backend_invoke_closure at gsettingsbackend.c:271
 #15 g_main_context_invoke_full at gmain.c:4987

Comment 1 unix63 2012-12-02 00:44:13 UTC
Created attachment 655776 [details]
File: backtrace

Comment 2 unix63 2012-12-02 00:44:15 UTC
Created attachment 655777 [details]
File: cgroup

Comment 3 unix63 2012-12-02 00:44:18 UTC
Created attachment 655778 [details]
File: core_backtrace

Comment 4 unix63 2012-12-02 00:44:21 UTC
Created attachment 655779 [details]
File: dso_list

Comment 5 unix63 2012-12-02 00:44:24 UTC
Created attachment 655780 [details]
File: environ

Comment 6 unix63 2012-12-02 00:44:26 UTC
Created attachment 655781 [details]
File: limits

Comment 7 unix63 2012-12-02 00:44:31 UTC
Created attachment 655782 [details]
File: maps

Comment 8 unix63 2012-12-02 00:44:34 UTC
Created attachment 655783 [details]
File: open_fds

Comment 9 unix63 2012-12-02 00:44:38 UTC
Created attachment 655784 [details]
File: proc_pid_status

Comment 10 unix63 2012-12-02 00:44:40 UTC
Created attachment 655785 [details]
File: var_log_messages

Comment 11 Fedora Update System 2012-12-04 02:52:05 UTC
mate-file-manager-1.5.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-file-manager-1.5.2-1.fc18

Comment 12 Fedora Update System 2012-12-04 21:09:56 UTC
Package mate-file-manager-1.5.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-file-manager-1.5.2-1.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19647/mate-file-manager-1.5.2-1.fc18
then log in and leave karma (feedback).

Comment 13 Dan Mashal 2012-12-06 04:36:38 UTC
*** Bug 883275 has been marked as a duplicate of this bug. ***

Comment 14 fred smith 2012-12-10 15:37:50 UTC
I've just installed F18 beta, from the netinstall ISO, on my eeepc, where it mostly seems to work just fine, though I haven't tested everything. After installing, I ran the system updater and it installed over 300 updates.

HOWEVER, using the MATE desktop, this bug still occurs, even though YUM reports that I have mate-file-manager-1.5.2-1.fc18 already.

I would think that since it's the same package version # as the one from 'testing', that it is in fact the same package. Am I wrong?

Also, in addition to this bug, even though the radio buttons show it defaulting to "single click", it in fact requires a double-click. Changing that behavior (i.e., to single-click) in other desktop environments (Cinnamon, XFCE) works fine in those DEs, but in Mate it still requires a double-click.

Comment 15 fred smith 2012-12-10 15:51:53 UTC
(In reply to comment #14)
> I've just installed F18 beta, from the netinstall ISO, on my eeepc, where it
> mostly seems to work just fine, though I haven't tested everything. After
> installing, I ran the system updater and it installed over 300 updates.
> 
> HOWEVER, using the MATE desktop, this bug still occurs, even though YUM
> reports that I have mate-file-manager-1.5.2-1.fc18 already.
> 
> I would think that since it's the same package version # as the one from
> 'testing', that it is in fact the same package. Am I wrong?
> 
> Also, in addition to this bug, even though the radio buttons show it
> defaulting to "single click", it in fact requires a double-click. Changing
> that behavior (i.e., to single-click) in other desktop environments
> (Cinnamon, XFCE) works fine in those DEs, but in Mate it still requires a
> double-click.

[later...]
I did a "yum reinstall" to force the testing package into place, rebooted, and there is no change: it still crashes every OTHER time you select "double-click", always defaults to single-click no matter what you last chose, and single-click does not work even when you choose it.

Comment 16 Dan Mashal 2012-12-12 03:16:54 UTC
Hi Fred, thanks for your report. I will take it up with upstream and try to reproduce locally. This Caja version DID fix a lot of bugs though. 

Can you do a fpaste -qa |grep mate can paste your .xsession_errors and /var/log/messages?

Thanks,
Dan

Comment 17 fred smith 2012-12-13 01:04:13 UTC
sorry, I'm not fluent in fpaste,... if you can guide me by being more specific re exactly what I should do I'd be happy to help.

Comment 18 fred smith 2012-12-13 01:36:47 UTC
Created attachment 662705 [details]
backtrace in gdb following the crash.

started caja (from commandline), attached GDB to the running PID.
In the caja window:
click EDIT
click PREFERENCES
click BEHAVIOR
the radio button for "Behavior" was set as Single click. (note that single click doesn't actually work to open anything, you still must double-click to open any items)
click Double Click.
click the close button
reopen EDIT / PREFERENCES / BEHAVIOR and note that it still says Single click.
Click Double click again
BOOOOOOMMMMMMM!

Comment 19 Dan Mashal 2012-12-14 08:18:45 UTC
Sorry the correct command is "rpm -qa |grep mate |fpaste"

Comment 20 fred smith 2012-12-14 13:37:31 UTC
http://paste.stg.fedoraproject.org/2547/

the output of rpm -qa | grep -y mate | fpaste

.xsession-errors (the entire file):
** (nm-applet:1394): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

** (abrt:1397): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
** Message: applet now removed from the notification area

** (mate-power-manager:1380): WARNING **: Failed to get brightness: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: Method "GetBrightness" with signature "" on interface "org.freedesktop.UPower.KbdBacklight" doesn't exist

** Message: applet now embedded in the notification area

** (mate-power-manager:1380): WARNING **: levels is 0!




excerpt from /var/log/messages:
Dec 14 08:26:13 eeepcbox kernel: [  176.002654] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
Dec 14 08:31:07 eeepcbox NetworkManager[644]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted
Dec 14 08:31:42 eeepcbox systemd-logind[580]: New session 2 of user fredex.
Dec 14 08:32:30 eeepcbox kernel: [  553.724464] caja[1365]: segfault at 11 ip 41aea4e8 sp bf88a09c error 4 in libc-2.16.so[4199c000+1b0000]
Dec 14 08:32:31 eeepcbox abrtd: Directory 'ccpp-2012-12-14-08:32:31-1365' creation detected
Dec 14 08:32:31 eeepcbox abrt[1596]: Saved core dump of pid 1365 (/usr/bin/caja) to /var/spool/abrt/ccpp-2012-12-14-08:32:31-1365 (57954304 bytes)
Dec 14 08:32:31 eeepcbox abrt[1596]: Lock file '/var/spool/abrt/ccpp-2012-12-12-12:44:05-1339/.lock' is locked by process 564
Dec 14 08:32:32 eeepcbox abrtd: Generating backtrace
Dec 14 08:32:32 eeepcbox dbus-daemon[589]: dbus[589]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.62" (uid=1000 pid=1599 comm="caja ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.13" (uid=0 pid=740 comm="/usr/sbin/console-kit-daemon --no-daemon ")
Dec 14 08:32:32 eeepcbox dbus[589]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.62" (uid=1000 pid=1599 comm="caja ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.13" (uid=0 pid=740 comm="/usr/sbin/console-kit-daemon --no-daemon ")
Dec 14 08:32:38 eeepcbox abrtd: Duplicate: core backtrace
Dec 14 08:32:38 eeepcbox abrtd: DUP_OF_DIR: /var/spool/abrt/ccpp-2012-12-09-21:31:30-1298
Dec 14 08:32:38 eeepcbox abrtd: Corrupted or bad directory '/var/spool/abrt/ccpp-2012-12-14-08:32:31-1365', deleting
Dec 14 08:33:48 eeepcbox dbus-daemon[589]: dbus[589]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Dec 14 08:33:48 eeepcbox dbus[589]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Dec 14 08:33:48 eeepcbox dbus-daemon[589]: Launching FprintObject
Dec 14 08:33:48 eeepcbox dbus-daemon[589]: dbus[589]: [system] Successfully activated service 'net.reactivated.Fprint'
Dec 14 08:33:48 eeepcbox dbus[589]: [system] Successfully activated service 'net.reactivated.Fprint'
Dec 14 08:33:48 eeepcbox dbus-daemon[589]: ** Message: D-Bus service launched with name: net.reactivated.Fprint
Dec 14 08:33:48 eeepcbox dbus-daemon[589]: ** Message: entering main loop
Dec 14 08:34:19 eeepcbox dbus-daemon[589]: ** Message: No devices in use, exit

Comment 21 fred smith 2012-12-14 13:51:27 UTC
Created attachment 663598 [details]
corefile dropped by caja when it crashes

coredump from the caja death event.

Comment 22 Dan Mashal 2012-12-26 06:42:59 UTC
Please run "su -c 'yum update --enablerepo-updates-testing'" and reopen this bug if you are still having issues.

Comment 23 fred smith 2012-12-27 17:26:36 UTC
it may be closed, but updates-testing does not yield a new caja RPM when running "su -c 'yum update --enablerepo updates-testing'", so I cannot test it.

Comment 24 Fedora Update System 2013-01-11 23:14:39 UTC
mate-file-manager-1.5.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 fred smith 2013-01-18 14:38:05 UTC
but 1.5.2-1.fc18 is the version we already had, so yum finds no update for it.

on my F18 system, even since the release and all the related updates came down, mate file manager is still broken as described above.

Am I overlooking something here?

Comment 26 Arnaud 2013-02-20 21:07:26 UTC
Got the same bug with 1.5.2-2.fc18.

About each time I try to change a setting in the Caja.
(ask dialog for script, and simple/double click)


Note You need to log in before you can comment on or make changes to this bug.