Bug 88260 - Texture, depth buffer and shading corruption when using OpenGL, DRI + r128 drivers.
Texture, depth buffer and shading corruption when using OpenGL, DRI + r128 dr...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-08 05:54 EDT by Rich Wareham
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 06:30:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rich Wareham 2003-04-08 05:54:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Texture, depth buffer and shading corruption when using OpenGL, DRI + r128
drivers. Fresh upgrade from RH 8.0 to RH 9. No previous problems with RH 8.0.

Screenshots showing corruption available at
http://rjw57.robinson.cam.ac.uk/~rjw57/r128_bugs/

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
Run some OpenGL program using the r128 drivers that come with RH 9.

Additional info:

Not tried reproducing with upstream release of X. Quick google for previous (non
RH-related) problems with r128 driver turns up nothing. Similarly the XF86 CVS
ChangeLog mention any fix for a similar problem.

XF86Config is standard one generated by install. Unmodified since then.
Comment 1 Mike A. Harris 2003-04-08 06:39:34 EDT
This looks like a Mesa bug of some kind, probably in the R128 Mesa DRI
driver.  Please report this bug directly to the DRI project via the
XFree86.org bugzilla:  http://bugs.xfree86.org

I will track the DRI project's progress on the issue and if a patch becomes
available, I'll add it to future XFree86 packages.

Please update this bug report once you've filed it upstream and provide
the URL so I can track it.

Thanks.
Comment 2 Rich Wareham 2003-04-08 07:12:59 EDT
Reported to upstream bugzilla, bug #120:

http://bugs.xfree86.org/cgi-bin/bugzilla/show_bug.cgi?id=120
Comment 3 Mike A. Harris 2003-04-08 07:41:37 EDT
Thanks for the quick update.
Comment 4 Mike A. Harris 2003-04-12 11:55:02 EDT
Thanks.  Changing status to UPSTREAM.  I'll scan the upstream bug report
from time to time to see if it has been fixed, and see if it can be
backported if possible.  If you find any new information, feel free to add
it here and there also.
Comment 5 Mike A. Harris 2004-09-01 06:30:50 EDT
Updating upstream bug URL for reference:

    http://bugs.xfree86.org/show_bug.cgi?id=120


The upstream URL indicates this is believed to be fixed in newer
release of DRI/Mesa code, which has since been integrated into
XFree86 (and thus X.Org X11 also, which is our current X11
implementation).

Closing bug as "RAWHIDE".  If the problem persists in rawhide
xorg-x11-6.7.99.903, you can file a bug report to the current
upstream bugzilla, which is http://bugs.freedesktop.org in the
"xorg" component.  The DRI project has merged into X.Org,
so X.Org bugzilla is the official DRI bugzilla now.  If you
do continue to reproduce the problem, and file a bug report in
X.Org bugzilla, if you also paste the new bug URL here, and
reopen, we will track the issue upstream in the new location.

Thanks in advance for testing the new X release.
Comment 6 Mike A. Harris 2004-09-01 06:31:49 EDT
Removing supplied hyperlink from URL field as the link is no longer
valid:  http://rjw57.robinson.cam.ac.uk/~rjw57/r128_bugs

Note You need to log in before you can comment on or make changes to this bug.