Bug 882633 - no graphical splash after upgrade to F18 Beta
Summary: no graphical splash after upgrade to F18 Beta
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-02 12:24 UTC by Kamil Páral
Modified: 2014-02-05 13:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-05 13:30:17 UTC
Type: Bug


Attachments (Terms of Use)
plymouth-debug.log (133.70 KB, text/plain)
2012-12-02 12:25 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2012-12-02 12:24:45 UTC
Description of problem:
In Fedora 17 the graphical plymouth splash worked perfect. With Fedora 18 Beta LiveCD it works as well. But when I upgraded from F17 to F18 Beta, I now get only text plymouth boot progress, no graphics.

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)

$ cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-3.6.7-5.fc18.x86_64 root=/dev/mapper/vg-lv_root ro root=/dev/mapper/vg-lv_root ro rd.md=0 rd.dm=0 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rd.luks.uuid=luks-b07a401c-96a9-47ab-8569-ac1809a1a1b9 rd.lvm.lv=vg/lv_root rd.lvm.lv=vg/lv_swap LANG=en_US.UTF-8 rhgb quiet plymouth:debug

plymouth debug log attached.

These messages look suspicious:
[ply-renderer.c]                      ply_renderer_open_plugin:trying to open renderer plugin /usr/lib64/plymouth/renderers/x11.so
[ply-utils.c]                               ply_open_module:Could not load module "/usr/lib64/plymouth/renderers/x11.so": /usr/lib
64/plymouth/renderers/x11.so: cannot open shared object file: No such file or directory
...
[main.c]              find_distribution_default_splash:Distribution default splash is configured to be 'spinner'
[main.c]                           show_default_splash:Trying distribution default splash
[main.c]                             start_boot_splash:Loading boot splash theme '/usr/share/plymouth/themes/spinner/spinner.plymouth'
[ply-key-file.c]                        ply_key_file_open_file:Failed to open key file /usr/share/plymouth/themes/spinner/spinner.plymouth: No such file or directory
...
[main.c]                             start_boot_splash:Loading boot splash theme '/usr/share/plymouth/themes/default.plymouth'
[ply-key-file.c]                        ply_key_file_open_file:Failed to open key file /usr/share/plymouth/themes/default.plymouth: No such file or directory



Version-Release number of selected component (if applicable):
plymouth-0.8.8-3.fc18.x86_64
plymouth-core-libs-0.8.8-3.fc18.x86_64
plymouth-graphics-libs-0.8.8-3.fc18.x86_64
plymouth-plugin-label-0.8.8-3.fc18.x86_64
plymouth-plugin-two-step-0.8.8-3.fc18.x86_64
plymouth-scripts-0.8.8-3.fc18.x86_64
plymouth-system-theme-0.8.8-3.fc18.x86_64
plymouth-theme-charge-0.8.8-3.fc18.x86_64


How reproducible:
always

Steps to Reproduce:
1. upgrade from F17 to F18
2. boot

Comment 1 Kamil Páral 2012-12-02 12:25:32 UTC
Created attachment 655938 [details]
plymouth-debug.log

Comment 2 Kamil Páral 2012-12-02 12:34:55 UTC
$ sudo dracut -f
didn't help.

$ sudo plymouth-set-default-theme -l
charge
details
text
(I don't know which one of those is set as default)

Comment 3 Ray Strode [halfline] 2012-12-04 23:02:33 UTC
it looks like spinner is your current default, though not installed.

does yum install plymouth-theme-spinner and then dracut -f fix it?

I wonder how spinner became your default.

Comment 4 Kamil Páral 2012-12-05 20:24:20 UTC
Ray, the approach form comment 3 fixed the issue for me. But I learned that spinner is not the theme Fedora uses by default (unless some change has been done in F18 very recently). So I removed it again, and used
$ sudo plymouth-set-default-theme charge
which finally reverted me back to the good old theme. However, I must not use this
$ sudo plymouth-set-default-theme -r
because it reverts it back to text theme again (even though I though charge was the default one).

My upgrade log is in attachment 655735 [details]. Do you see any reason why would the plymouth theme change during upgrade? Please note I have used plymouth.splash=fedup as boot argument to fedup to work around bug 879295. Can it be the cause?

I don't think this has been once-in-a-lifetime glitch, so more people will probably hit it once they start massively upgrading to F18.

Comment 5 Kamil Páral 2013-01-11 11:37:24 UTC
I tried to reproduce with F17->F18 Final upgrade and everything worked correctly, I had "charge" theme afterwards. So either this was fixed in the meantime, or there was something in my previous configuration that caused it. Can't reproduce in a VM.

Comment 6 Brandon 2013-02-22 16:02:40 UTC
Here is a solution that restores the splash if you have nvidia drivers installed or ATI..  My resolution is 1280x1024x32. This might work for you, it might not.

add the following to  /etc/default/grub

GRUB_GFXMODE=1280x1024x32
GRUB_GFXPAYLOAD=keep
GRUB_GFXPAYLOAD_LINUX=1280x1024x32

then run the following command

grub2-mkconfig -o /boot/grub2/grub.cfg


Source: http://forums.fedoraforum.org/showthread.php?t=280259

Nvidia 250 GTS is my card.

Comment 7 Fedora End Of Life 2013-12-21 09:36:14 UTC
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 8 Fedora End Of Life 2014-02-05 13:30:21 UTC
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.