This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 882635 - [abrt] java-1.7.0-openjdk-1.7.0.9-2.3.3.fc18.1: handle_error: Process /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9.x86_64/jre/bin/java was killed by signal 5 (SIGTRAP)
[abrt] java-1.7.0-openjdk-1.7.0.9-2.3.3.fc18.1: handle_error: Process /usr/li...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
abrt_hash:8a35e0ec6b57f71973ad39c09b1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-02 07:30 EST by Jindrich Novy
Modified: 2013-07-02 19:58 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-21 10:18:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (128.44 KB, text/plain)
2012-12-02 07:30 EST, Jindrich Novy
no flags Details
File: build_ids (5.29 KB, text/plain)
2012-12-02 07:30 EST, Jindrich Novy
no flags Details
File: cgroup (128 bytes, text/plain)
2012-12-02 07:30 EST, Jindrich Novy
no flags Details
File: dso_list (28.61 KB, text/plain)
2012-12-02 07:30 EST, Jindrich Novy
no flags Details
File: environ (1.60 KB, text/plain)
2012-12-02 07:30 EST, Jindrich Novy
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-02 07:31 EST, Jindrich Novy
no flags Details
File: maps (92.66 KB, text/plain)
2012-12-02 07:31 EST, Jindrich Novy
no flags Details
File: open_fds (4.55 KB, text/plain)
2012-12-02 07:31 EST, Jindrich Novy
no flags Details
File: proc_pid_status (916 bytes, text/plain)
2012-12-02 07:31 EST, Jindrich Novy
no flags Details
File: var_log_messages (673 bytes, text/plain)
2012-12-02 07:31 EST, Jindrich Novy
no flags Details

  None (edit)
Description Jindrich Novy 2012-12-02 07:30:37 EST
Description of problem:
Restarting Eclipse

Version-Release number of selected component:
java-1.7.0-openjdk-1.7.0.9-2.3.3.fc18.1

Additional info:
backtrace_rating: 3
cmdline:        /usr/bin/java -Xms128m -Xmx512m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -XX:MaxPermSize=256m -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20121126-1152.jar -os linux -ws gtk -arch x86_64 -showsplash /usr/lib64/eclipse//plugins/org.eclipse.platform_4.2.1.v20121126-1152/splash.bmp -launcher /usr/lib64/eclipse/eclipse -name Eclipse --launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20121126-1152/eclipse_1503.so -startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20121126-1152.jar --launcher.overrideVmargs -exitdata 1a3a0014 -preventMasterEclipseLaunch -vm /usr/bin/java -vmargs -Xms128m -Xmx512m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -XX:MaxPermSize=256m -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20121126-1152.jar
core_backtrace: 
crash_function: handle_error
executable:     /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.9.x86_64/jre/bin/java
kernel:         3.6.7-5.fc18.x86_64
remote_result:  NOTFOUND
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 handle_error at xcb_io.c:212
 #5 handle_response at xcb_io.c:324
 #8 _cairo_xlib_shm_surface_flush at cairo-xlib-surface-shm.c:640
 #9 *INT_cairo_surface_flush at cairo-surface.c:1494
 #10 INT_cairo_surface_flush at cairo-surface.c:1484
 #11 _cairo_xlib_surface_discard_shm at cairo-xlib-surface.c:369
 #12 _cairo_xlib_surface_finish at cairo-xlib-surface.c:401
 #13 _cairo_surface_finish at cairo-surface.c:1007
 #14 *INT_cairo_surface_destroy at cairo-surface.c:945
 #15 INT_cairo_surface_destroy at cairo-surface.c:924
Comment 1 Jindrich Novy 2012-12-02 07:30:45 EST
Created attachment 655941 [details]
File: backtrace
Comment 2 Jindrich Novy 2012-12-02 07:30:47 EST
Created attachment 655944 [details]
File: build_ids
Comment 3 Jindrich Novy 2012-12-02 07:30:52 EST
Created attachment 655948 [details]
File: cgroup
Comment 4 Jindrich Novy 2012-12-02 07:30:55 EST
Created attachment 655950 [details]
File: dso_list
Comment 5 Jindrich Novy 2012-12-02 07:30:57 EST
Created attachment 655953 [details]
File: environ
Comment 6 Jindrich Novy 2012-12-02 07:31:00 EST
Created attachment 655956 [details]
File: limits
Comment 7 Jindrich Novy 2012-12-02 07:31:02 EST
Created attachment 655958 [details]
File: maps
Comment 8 Jindrich Novy 2012-12-02 07:31:05 EST
Created attachment 655961 [details]
File: open_fds
Comment 9 Jindrich Novy 2012-12-02 07:31:07 EST
Created attachment 655964 [details]
File: proc_pid_status
Comment 10 Jindrich Novy 2012-12-02 07:31:09 EST
Created attachment 655966 [details]
File: var_log_messages
Comment 11 Daniel Rindt 2012-12-04 18:07:34 EST
running eclipse

backtrace_rating: 3
Package: java-1.7.0-openjdk-1.7.0.9-2.3.3.fc18.1
OS Release: Fedora release 18 (Spherical Cow)
Comment 12 Severin Gehwolf 2012-12-05 04:48:19 EST
This looks like an eclipse (webkit?) issue to me. Reassigning component.
Comment 13 Alexander Kurtakov 2012-12-18 14:52:32 EST
Would you please whether https://koji.fedoraproject.org/koji/buildinfo?buildID=373489 fixes the problem? It looks to me like we expose some cairo bug.
Comment 14 Alexander Kurtakov 2013-01-21 10:18:27 EST
Long time no reply. Closing.

Note You need to log in before you can comment on or make changes to this bug.